summaryrefslogtreecommitdiff
path: root/dev-libs/libdynd/libdynd-0.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-libs/libdynd/libdynd-0.7.2.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-libs/libdynd/libdynd-0.7.2.ebuild')
-rw-r--r--dev-libs/libdynd/libdynd-0.7.2.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-libs/libdynd/libdynd-0.7.2.ebuild b/dev-libs/libdynd/libdynd-0.7.2.ebuild
index 2f1c96031bd5..90d8c02bb873 100644
--- a/dev-libs/libdynd/libdynd-0.7.2.ebuild
+++ b/dev-libs/libdynd/libdynd-0.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw mkl test"
+IUSE="cuda doc fftw test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -49,11 +49,6 @@ src_prepare() {
-e '/git_describe/d' \
-e '/dirty/d' \
-i CMakeLists.txt || die
- # not tested
- if use mkl; then
- sed -e "s|/opt/intel/.*|$(ls -1d ${EPREFIX}/opt/intel/compilers*)|" \
- -i tests/CMakeLists.txt || die
- fi
}
src_configure() {
@@ -64,12 +59,10 @@ src_configure() {
-DDYND_SHARED_LIB=ON
-DDYND_BUILD_BENCHMARKS=OFF
-DDYND_BUILD_DOCS="$(usex doc)"
- -DDYND_BUILD_PLUGIN="$(usex mkl)"
-DDYND_BUILD_TESTS="$(usex test)"
- -DDYND_CUDA="$(usex cuda)"
-DDYND_FFTW="$(usex fftw)"
- -DFFTW_PATH="${EPREFIX}/usr/include"
)
+ use fftw && mycmakeargs+=( -DFFTW_PATH="${EPREFIX}/usr/include" )
cmake-utils_src_configure
}