summaryrefslogtreecommitdiff
path: root/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild')
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
new file mode 100644
index 000000000000..6e760fbd0f14
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="http://www.monkey.org/~provos/libdnsres/"
+SRC_URI="http://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+}