summaryrefslogtreecommitdiff
path: root/dev-libs/libdaemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libdaemon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libdaemon')
-rw-r--r--dev-libs/libdaemon/Manifest6
-rw-r--r--dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch38
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r1.ebuild57
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r2.ebuild68
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r3.ebuild67
-rw-r--r--dev-libs/libdaemon/metadata.xml7
6 files changed, 243 insertions, 0 deletions
diff --git a/dev-libs/libdaemon/Manifest b/dev-libs/libdaemon/Manifest
new file mode 100644
index 000000000000..41b2298d9304
--- /dev/null
+++ b/dev-libs/libdaemon/Manifest
@@ -0,0 +1,6 @@
+AUX 0.14-man-page-typo-fix.patch 1562 BLAKE2B 3e0bc53ca9cbe959ba6360c6226ee99a822bdd78918791bdcf367775d9f80a9bfcf7e82dcd3b4f45c4f10af31be1bacf4ecdbe119482ac6ee705d99967cf9826 SHA512 19aafe2b9d39484ad01544ad3c7937d98b0e8216de1ed8cd331106004f565a6c094888f1a0fd1f540c790728274079343d5db060a0e1a9647d600cea675994d1
+DIST libdaemon-0.14.tar.gz 340474 BLAKE2B 1dd6ac48e7b9a31f58688c7a59814435059287a30db80dd7c9cf69f9eaba27245424ecdbfd8719a4cf30d9686f4b61bb5e394821f66c05e770c244a0208e8f3f SHA512 a96b25c09bd63cc192c1c5f8b5bf34cc6ad0c32d42ac14b520add611423b6ad3d64091a47e0c7ab9a94476a5e645529abccea3ed6b23596567163fba88131ff2
+EBUILD libdaemon-0.14-r1.ebuild 1199 BLAKE2B 5dfa0749f2f582edc5003f4c1d9bf4f00d4100ad62d5ff058ea4a996d5e6f23d5f4bd74e18be8b9afebf23bdd45a825c2de0b488652b047c38bbf0c81763e806 SHA512 a4f0679b5702353f0dc05cc959dbe1cacba004093a69430fa71a85e2d0be0a80c07603d3e62152ebc203e8dc0fca412b764614cf9ccabb291e0fbcbd3d0d2070
+EBUILD libdaemon-0.14-r2.ebuild 1446 BLAKE2B 4e43ad8358555b319685431f1f7f3b2598116060cfe0d3dac1f923f06bcfcd84438036dd17fb2e174df5ff8397332ce557d81541b8fe7455cfa2ab1abe3027e1 SHA512 dffc3b0c3bedd18a109b5831009aaa309023645d4b419cf9f3d718cfc6629b2e0de5c738b681a093a3f7207b8076d88abbca880a002c2e7c5e8f1256446ff892
+EBUILD libdaemon-0.14-r3.ebuild 1396 BLAKE2B 09219c6c961138369f1aeb7621330d619cd78fbe2304e8f953801779c09d37ad833be8234f7eefb5be7d9766d0fae1877124722a271f8219945cec1b5ea35305 SHA512 b09468047df48a997cadc3b0991b10f884c82e3c01ba6d7f22c966d9065178fa3da29e3d0d6210718cae67930e2718f71cab600fe55ad0f37d8033f1f41356b2
+MISC metadata.xml 214 BLAKE2B 33eeb62dd1e0788ebdae4c98136c1c6a3b94a197683d1056a2e0c08566d14cde6469852038c1c8a574141f422d7ed3559332415f8ae79ab0fc223bc5fb55a1b8 SHA512 9b8ba52023f39252d9fc270607a4b928d4c961c893ef4f722d7e2ac567c66a3de509849ef754e3c8fef73923144251e5ebcc19b0d2ec93b94ab79ffb5c17cb83
diff --git a/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch b/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch
new file mode 100644
index 000000000000..70a6a0eb931f
--- /dev/null
+++ b/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch
@@ -0,0 +1,38 @@
+Patch from Debian fixing typo that appears in man page.
+
+
+diff --git a/examples/testd.c b/examples/testd.c
+index 6557dff..f734173 100644
+--- a/examples/testd.c
++++ b/examples/testd.c
+@@ -87,7 +87,7 @@ int main(int argc, char *argv[]) {
+
+ /* Wait for 20 seconds for the return value passed from the daemon process */
+ if ((ret = daemon_retval_wait(20)) < 0) {
+- daemon_log(LOG_ERR, "Could not recieve return value from daemon process: %s", strerror(errno));
++ daemon_log(LOG_ERR, "Could not receive return value from daemon process: %s", strerror(errno));
+ return 255;
+ }
+
+diff --git a/libdaemon/dsignal.h b/libdaemon/dsignal.h
+index 1719784..4030e41 100644
+--- a/libdaemon/dsignal.h
++++ b/libdaemon/dsignal.h
+@@ -34,7 +34,7 @@ extern "C" {
+ * wish to handle with select() in your main loop with
+ * daemon_signal_init() or daemon_signal_install(). After that you
+ * should sleep on the file descriptor returned by daemon_signal_fd()
+- * and get the next signal recieved with daemon_signal_next(). You
++ * and get the next signal received with daemon_signal_next(). You
+ * should call daemon_signal_done() before exiting.
+ */
+
+@@ -54,7 +54,7 @@ int daemon_signal_install(int s);
+ */
+ void daemon_signal_done(void);
+
+-/** Return the next signal recieved. This function will not
++/** Return the next signal received. This function will not
+ * block. Instead it returns 0 if no signal is queued.
+ * @return The next queued signal if one is queued, zero if none is
+ * queued, negative on failure.
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
new file mode 100644
index 000000000000..220ed1033ba8
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit libtool eutils
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( "README" )
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html doc/style.css reference
+ doman doc/reference/man/man*/*
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+
+ rm -rf "${ED}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
+}
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild
new file mode 100644
index 000000000000..6de3cea08773
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit libtool eutils multilib-minimal
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( "README" )
+
+src_prepare() {
+ epatch_user
+
+ # doxygen is broken with out-of-source builds
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html doc/style.css reference
+ doman doc/reference/man/man*/*
+ fi
+
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+
+ rm "${ED}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
+}
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild
new file mode 100644
index 000000000000..98b6228b3335
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-man-page-typo-fix.patch
+)
+
+src_prepare() {
+ default
+
+ # doxygen is broken with out-of-source builds
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/README.html doc/style.css doc/reference/html/*
+ doman doc/reference/man/man3/*.h.3
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+}
diff --git a/dev-libs/libdaemon/metadata.xml b/dev-libs/libdaemon/metadata.xml
new file mode 100644
index 000000000000..03f633b16af3
--- /dev/null
+++ b/dev-libs/libdaemon/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>