summaryrefslogtreecommitdiff
path: root/dev-libs/libcpuid/libcpuid-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 17:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 17:20:42 +0100
commit09f46eb2a6639c039b0b4268a8410d93bbf14e9e (patch)
treed1420dd9d7fd41dd0e684e1d13737b4da195a5ae /dev-libs/libcpuid/libcpuid-0.6.3.ebuild
parent7837a76c344b64e925519dd5e26233bb3b648beb (diff)
gentoo auto-resync : 03:04:2023 - 17:20:42
Diffstat (limited to 'dev-libs/libcpuid/libcpuid-0.6.3.ebuild')
-rw-r--r--dev-libs/libcpuid/libcpuid-0.6.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libcpuid/libcpuid-0.6.3.ebuild b/dev-libs/libcpuid/libcpuid-0.6.3.ebuild
new file mode 100644
index 000000000000..75cb5bcb7074
--- /dev/null
+++ b/dev-libs/libcpuid/libcpuid-0.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{9..11})
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A small C library for x86 (and x86_64) CPU detection and feature extraction"
+HOMEPAGE="http://libcpuid.sourceforge.net/"
+SRC_URI="https://github.com/anrieff/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/16"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_enable static-libs static)"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}