summaryrefslogtreecommitdiff
path: root/dev-libs/libconfig/libconfig-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libconfig/libconfig-1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libconfig/libconfig-1.5.ebuild')
-rw-r--r--dev-libs/libconfig/libconfig-1.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libconfig/libconfig-1.5.ebuild b/dev-libs/libconfig/libconfig-1.5.ebuild
new file mode 100644
index 000000000000..1f9cc4f295f0
--- /dev/null
+++ b/dev-libs/libconfig/libconfig-1.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+inherit eutils autotools-multilib
+
+DESCRIPTION="Libconfig is a simple library for manipulating structured configuration files"
+HOMEPAGE="http://www.hyperrealm.com/libconfig/libconfig.html"
+SRC_URI="http://www.hyperrealm.com/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~mips ppc ~ppc64 sparc x86 ~x86-linux"
+IUSE="+cxx examples static-libs"
+
+DEPEND="
+ sys-devel/libtool
+ sys-devel/bison"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5-out-of-source-build.patch" )
+
+src_prepare() {
+ sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable cxx)
+ --disable-examples
+ )
+ autotools-utils_src_configure
+}
+
+multilib_src_test() {
+ # It responds to check but that does not work as intended
+ emake test
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+
+ if use examples; then
+ find examples -name "Makefile.*" -delete || die
+ dodoc -r examples
+ fi
+}