summaryrefslogtreecommitdiff
path: root/dev-libs/libclc/libclc-14.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
commitb6a0f46f7d2e1e21df70fb32169f7d9de85445f7 (patch)
tree2f1b6f7c25e85d70d737cd66c68673ed58e1108e /dev-libs/libclc/libclc-14.0.6.ebuild
parent9173f73d44f3cbc858477bd71e7680ede7d98e0d (diff)
gentoo auto-resync : 22:12:2023 - 19:52:05
Diffstat (limited to 'dev-libs/libclc/libclc-14.0.6.ebuild')
-rw-r--r--dev-libs/libclc/libclc-14.0.6.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-libs/libclc/libclc-14.0.6.ebuild b/dev-libs/libclc/libclc-14.0.6.ebuild
deleted file mode 100644
index 5464d123288a..000000000000
--- a/dev-libs/libclc/libclc-14.0.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake llvm llvm.org python-any-r1
-
-DESCRIPTION="OpenCL C library"
-HOMEPAGE="https://libclc.llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_r600 video_cards_radeonsi"
-IUSE="${IUSE_VIDEO_CARDS}"
-REQUIRED_USE="|| ( ${IUSE_VIDEO_CARDS} )"
-
-LLVM_MAX_SLOT=14
-BDEPEND="
- ${PYTHON_DEPS}
- || (
- sys-devel/clang:14
- sys-devel/clang:13
- )
-"
-
-LLVM_COMPONENTS=( libclc )
-llvm.org_set_globals
-
-llvm_check_deps() {
- has_version -b "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- # we do not need llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local libclc_targets=()
-
- use video_cards_nvidia && libclc_targets+=(
- "nvptx--"
- "nvptx64--"
- "nvptx--nvidiacl"
- "nvptx64--nvidiacl"
- )
- use video_cards_r600 && libclc_targets+=(
- "r600--"
- )
- use video_cards_radeonsi && libclc_targets+=(
- "amdgcn--"
- "amdgcn-mesa-mesa3d"
- "amdgcn--amdhsa"
- )
- # TODO: spirv
- [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
-
- libclc_targets=${libclc_targets[*]}
- local mycmakeargs=(
- -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
- -DLLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
- )
- cmake_src_configure
-}