summaryrefslogtreecommitdiff
path: root/dev-libs/libcdio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/libcdio/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libcdio/files')
-rw-r--r--dev-libs/libcdio/files/libcdio-1.0.0-cddb.patch37
-rw-r--r--dev-libs/libcdio/files/libcdio-1.0.0-version.patch16
-rw-r--r--dev-libs/libcdio/files/libcdio-2.0.0-iso-ioleak.patch37
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-libs/libcdio/files/libcdio-1.0.0-cddb.patch b/dev-libs/libcdio/files/libcdio-1.0.0-cddb.patch
deleted file mode 100644
index b3781d2a7e51..000000000000
--- a/dev-libs/libcdio/files/libcdio-1.0.0-cddb.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 4305bc1e093e4341aeddb857bd1e6203228000cb Mon Sep 17 00:00:00 2001
-From: "R. Bernstein" <rocky@gnu.org>
-Date: Sat, 25 Nov 2017 14:03:37 -0500
-Subject: Fix breakage caused by unshadowing i_first_track
-
-Reported and patch by KO Myung-Hun
----
- src/cdda-player.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/cdda-player.c b/src/cdda-player.c
-index efeee19..333e1f5 100644
---- a/src/cdda-player.c
-+++ b/src/cdda-player.c
-@@ -531,8 +531,8 @@ static void
- get_cddb_disc_info(CdIo_t *p_cdio)
- {
- #ifdef HAVE_CDDB
-- b_db = init_cddb(p_cdio, &p_conn, &p_cddb_disc, xperror, i_first_track,
-- i_tracks, &i_cddb_matches);
-+ b_db = init_cddb(p_cdio, &p_conn, &p_cddb_disc, xperror, i_first_track_global,
-+ i_tracks_global, &i_cddb_matches);
- if (b_db) {
- int i_year;
- i_year = atoi(year);
-@@ -831,7 +831,7 @@ get_cddb_track_info(track_t i_track)
- {
- #ifdef HAVE_CDDB
- cddb_track_t *t = cddb_disc_get_track(p_cddb_disc,
-- i_track - i_first_track);
-+ i_track - i_first_track_global);
- if (t) {
- cddb_track_set_title(t, title);
- cddb_track_set_artist(t, artist);
---
-cgit v1.0-41-gc330
-
diff --git a/dev-libs/libcdio/files/libcdio-1.0.0-version.patch b/dev-libs/libcdio/files/libcdio-1.0.0-version.patch
deleted file mode 100644
index bdde131ffc8e..000000000000
--- a/dev-libs/libcdio/files/libcdio-1.0.0-version.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -32,7 +32,12 @@
- m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])],
- [AC_SUBST([AM_DEFAULT_VERBOSITY], [1])])
-
--LIBCDIO_VERSION_NUM=`echo RELEASE_NUM | cut -d . -f 1 | tr -d a-z`
-+# Broken by design. See also
-+# https://savannah.gnu.org/bugs/?52491
-+# and
-+# http://git.savannah.gnu.org/cgit/libcdio.git/patch/?id=2d22ae18571caf29460a456340ff0603f04af6b4
-+#LIBCDIO_VERSION_NUM=`echo RELEASE_NUM | cut -d . -f 1 | tr -d a-z`
-+LIBCDIO_VERSION_NUM=10000
- AC_SUBST(LIBCDIO_VERSION_NUM)
-
- AM_MISSING_PROG(HELP2MAN, help2man, $missing_dir)
diff --git a/dev-libs/libcdio/files/libcdio-2.0.0-iso-ioleak.patch b/dev-libs/libcdio/files/libcdio-2.0.0-iso-ioleak.patch
deleted file mode 100644
index 17732104c3d1..000000000000
--- a/dev-libs/libcdio/files/libcdio-2.0.0-iso-ioleak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 8c0de2d3f0324ecf3fd135589589dcd783c15556 Mon Sep 17 00:00:00 2001
-From: rocky <rocky@gnu.org>
-Date: Fri, 16 Feb 2018 09:14:17 -0500
-Subject: Fix small I/O leak when we can't read ISO file
-
-See Savannah bug #53170. Thanks to David Binderman.
----
- src/iso-read.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/src/iso-read.c b/src/iso-read.c
-index 0541e27..8647485 100644
---- a/src/iso-read.c
-+++ b/src/iso-read.c
-@@ -1,5 +1,6 @@
- /*
-- Copyright (C) 2004-2006, 2008, 2012-2013, 2017 Rocky Bernstein <rocky@gnu.org>
-+ Copyright (C) 2004-2006, 2008, 2012-2013, 2017-2018 Rocky Bernstein
-+ <rocky@gnu.org>
-
- This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
-@@ -364,7 +365,10 @@ main(int argc, char *argv[])
- ret = read_iso_file (opts.iso9660_image, opts.file_name,
- outfd, &bytes_written);
- }
-- if (ret != 0) return ret;
-+ if (ret != 0) {
-+ fclose (outfd);
-+ return ret;
-+ }
-
- fflush (outfd);
-
---
-cgit v1.0-41-gc330
-