summaryrefslogtreecommitdiff
path: root/dev-libs/libbytesize/libbytesize-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libbytesize/libbytesize-1.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-1.2-r1.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-1.2-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/libbytesize-1.2-r1.ebuild b/dev-libs/libbytesize/libbytesize-1.2-r1.ebuild
new file mode 100644
index 000000000000..c916bc16687a
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-1.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE="doc test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --without-python3
+ $(use_with doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ python_install() {
+ emake -C src/python install DESTDIR="${D}"
+ python_optimize
+ }
+ python_foreach_impl python_install
+}