summaryrefslogtreecommitdiff
path: root/dev-libs/libbytesize/libbytesize-0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libbytesize/libbytesize-0.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-0.11.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-0.11.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/libbytesize-0.11.ebuild b/dev-libs/libbytesize/libbytesize-0.11.ebuild
new file mode 100644
index 000000000000..9a089877335e
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-0.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${CDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+"
+
+# https://github.com/rhinstaller/libbytesize/issues/27
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+}