summaryrefslogtreecommitdiff
path: root/dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild')
-rw-r--r--dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild b/dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild
index 4d2e451c2a30..63f386c80ec3 100644
--- a/dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild
+++ b/dev-libs/libbrahe/libbrahe-1.1.0-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils
+inherit autotools
DESCRIPTION="A Heterogenous C Library of Numeric Functions"
HOMEPAGE="http://www.coyotegulch.com/products/brahe/"
@@ -14,7 +13,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
DOCS=( AUTHORS ChangeLog NEWS )
-PATCHES=( "${FILESDIR}/${PV}-missing_libs.patch" )
+
+PATCHES=(
+ "${FILESDIR}/${PV}-missing_libs.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.a' -delete || die
+}