summaryrefslogtreecommitdiff
path: root/dev-libs/libbpf/libbpf-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/libbpf/libbpf-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/libbpf/libbpf-9999.ebuild')
-rw-r--r--dev-libs/libbpf/libbpf-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-libs/libbpf/libbpf-9999.ebuild b/dev-libs/libbpf/libbpf-9999.ebuild
index 08e5746d4bf0..6697b1c3a061 100644
--- a/dev-libs/libbpf/libbpf-9999.ebuild
+++ b/dev-libs/libbpf/libbpf-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
+
if [[ ${PV} =~ [9]{4,} ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/libbpf/libbpf.git"
@@ -11,8 +12,9 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
+S="${WORKDIR}/${P}/src"
-HOMEPAGE="https://www.kernel.org/doc/html/latest/bpf/bpf_devel_QA.html"
+HOMEPAGE="https://github.com/libbpf/libbpf"
DESCRIPTION="Stand-alone build of libbpf from the Linux kernel"
LICENSE="GPL-2 LGPL-2.1 BSD-2"
@@ -25,13 +27,12 @@ DEPEND="${COMMON_DEPEND}
sys-kernel/linux-headers"
RDEPEND="${COMMON_DEPEND}"
-S="${WORKDIR}/${P}/src"
-
PATCHES=(
"${FILESDIR}/libbpf-9999-paths.patch"
)
src_compile() {
+ append-cflags -fPIC
emake \
BUILD_SHARED=y \
LIBSUBDIR="$(get_libdir)" \