summaryrefslogtreecommitdiff
path: root/dev-libs/libbase58/libbase58-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libbase58/libbase58-0.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libbase58/libbase58-0.1.1.ebuild')
-rw-r--r--dev-libs/libbase58/libbase58-0.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libbase58/libbase58-0.1.1.ebuild b/dev-libs/libbase58/libbase58-0.1.1.ebuild
new file mode 100644
index 000000000000..c77b5cda8e25
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable tools tool)
+ )
+ autotools-utils_src_configure
+}