summaryrefslogtreecommitdiff
path: root/dev-libs/kuserfeedback/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-libs/kuserfeedback/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-libs/kuserfeedback/files')
-rw-r--r--dev-libs/kuserfeedback/files/kuserfeedback-1.0.0-fix-opengl-crash.patch39
-rw-r--r--dev-libs/kuserfeedback/files/kuserfeedback-1.2.0-enable_docs.patch48
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/kuserfeedback/files/kuserfeedback-1.0.0-fix-opengl-crash.patch b/dev-libs/kuserfeedback/files/kuserfeedback-1.0.0-fix-opengl-crash.patch
new file mode 100644
index 000000000000..57321355b23a
--- /dev/null
+++ b/dev-libs/kuserfeedback/files/kuserfeedback-1.0.0-fix-opengl-crash.patch
@@ -0,0 +1,39 @@
+From 17db7d75643b4f3dccd5b36a6ab175f03ba74297 Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Wed, 2 Feb 2022 20:36:40 +0100
+Subject: [PATCH] opengl source: Do not crash if we could not make our context
+ current
+
+BUG: 449505
+---
+ src/provider/core/openglinfosource.cpp | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/src/provider/core/openglinfosource.cpp b/src/provider/core/openglinfosource.cpp
+index 5117d85..08402c7 100644
+--- a/src/provider/core/openglinfosource.cpp
++++ b/src/provider/core/openglinfosource.cpp
+@@ -13,6 +13,7 @@
+ #include <QOpenGLFunctions>
+ #include <QSurfaceFormat>
+ #include <QWindow>
++#include "logging_p.h"
+ #endif
+
+ using namespace KUserFeedback;
+@@ -37,7 +38,11 @@ QVariant OpenGLInfoSource::data()
+ QWindow window;
+ window.setSurfaceType(QSurface::OpenGLSurface);
+ window.create();
+- context.makeCurrent(&window);
++ if (!context.makeCurrent(&window)) {
++ qCWarning(Log) << "Could not make OpenGL context current";
++ m.insert(QStringLiteral("type"), QStringLiteral("none"));
++ return m;
++ }
+ QOpenGLFunctions functions(&context);
+ m.insert(QStringLiteral("vendor"), OpenGLInfoSourcePrivate::normalizeVendor(reinterpret_cast<const char*>(functions.glGetString(GL_VENDOR))));
+ m.insert(QStringLiteral("renderer"), OpenGLInfoSourcePrivate::normalizeRenderer(reinterpret_cast<const char*>(functions.glGetString(GL_RENDERER))));
+--
+GitLab
+
diff --git a/dev-libs/kuserfeedback/files/kuserfeedback-1.2.0-enable_docs.patch b/dev-libs/kuserfeedback/files/kuserfeedback-1.2.0-enable_docs.patch
new file mode 100644
index 000000000000..77915f1b4040
--- /dev/null
+++ b/dev-libs/kuserfeedback/files/kuserfeedback-1.2.0-enable_docs.patch
@@ -0,0 +1,48 @@
+From f523d1da91dbf944cb753e8aed8ad40367e8826c Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 11 Feb 2022 12:29:50 +0100
+Subject: [PATCH] Hide finding docs dependencies behind ENABLE_DOCS
+
+It was also oddly placed within CMakeLists.txt so moved it below
+major Qt dependency calls (and the actual "# Dependencies" block).
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 14 ++++++++------
+ 1 file changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9ea764a..48623bc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,12 +39,6 @@ include(ECMGeneratePriFile)
+ include(FeatureSummary)
+ include(GenerateExportHeader)
+
+-if(QT_MAJOR_VERSION STREQUAL "5")
+- find_package(Qt5 CONFIG OPTIONAL_COMPONENTS DocTools)
+-else()
+- find_package(Qt6 CONFIG OPTIONAL_COMPONENTS ToolsTools)
+-endif()
+-
+ ecm_setup_version(PROJECT
+ VARIABLE_PREFIX KUSERFEEDBACK
+ VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/kuserfeedback_version.h"
+@@ -61,6 +55,14 @@ if (NOT CMAKE_CROSSCOMPILING)
+ find_package(Qt${QT_MAJOR_VERSION} NO_MODULE QUIET OPTIONAL_COMPONENTS Help)
+ endif()
+
++if (ENABLE_DOCS)
++ if(QT_MAJOR_VERSION STREQUAL "5")
++ find_package(Qt5 CONFIG OPTIONAL_COMPONENTS DocTools)
++ else()
++ find_package(Qt6 CONFIG OPTIONAL_COMPONENTS ToolsTools)
++ endif()
++endif()
++
+ set_package_properties(Qt${QT_MAJOR_VERSION} PROPERTIES URL "http://qt-project.org/")
+ set_package_properties(Qt${QT_MAJOR_VERSION}Widgets PROPERTIES TYPE RECOMMENDED PURPOSE "Required for feedback configuration and notification widgets.")
+ set_package_properties(Qt${QT_MAJOR_VERSION}Charts PROPERTIES TYPE RECOMMENDED PURPOSE "Required for UserFeedbackConsole.")
+--
+2.35.1
+