summaryrefslogtreecommitdiff
path: root/dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild')
-rw-r--r--dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild b/dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild
new file mode 100644
index 000000000000..794a4be96b8b
--- /dev/null
+++ b/dev-libs/kpublictransport/kpublictransport-22.04.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KDE_GEAR="true"
+KFMIN=5.92.0
+QTMIN=5.15.4
+inherit ecm kde.org
+
+DESCRIPTION="Library for accessing public transport timetables and other information"
+HOMEPAGE="https://invent.kde.org/libraries/kpublictransport
+ https://www.volkerkrause.eu/2019/03/02/kpublictransport-introduction.html"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}