summaryrefslogtreecommitdiff
path: root/dev-libs/kproperty/kproperty-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/kproperty/kproperty-3.2.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/kproperty/kproperty-3.2.0.ebuild')
-rw-r--r--dev-libs/kproperty/kproperty-3.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/kproperty/kproperty-3.2.0.ebuild b/dev-libs/kproperty/kproperty-3.2.0.ebuild
new file mode 100644
index 000000000000..a3ce3bb0b38c
--- /dev/null
+++ b/dev-libs/kproperty/kproperty-3.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="true"
+KDE_TEST="true" # build system adds autotests dir based on BUILD_TESTING value
+inherit kde5
+
+DESCRIPTION="Property editing framework with editor widget similar to Qt Designer"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="5/4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+# tests require installed headers, bug 636108
+RESTRICT+=" test"