summaryrefslogtreecommitdiff
path: root/dev-libs/kproperty/kproperty-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/kproperty/kproperty-3.2.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/kproperty/kproperty-3.2.0.ebuild')
-rw-r--r--dev-libs/kproperty/kproperty-3.2.0.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/dev-libs/kproperty/kproperty-3.2.0.ebuild b/dev-libs/kproperty/kproperty-3.2.0.ebuild
index ed6db995cc72..d0bd58ebea0e 100644
--- a/dev-libs/kproperty/kproperty-3.2.0.ebuild
+++ b/dev-libs/kproperty/kproperty-3.2.0.ebuild
@@ -1,27 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-KDE_QTHELP="true"
-KDE_TEST="true" # build system adds autotests dir based on BUILD_TESTING value
-inherit kde5
+ECM_QTHELP="true"
+ECM_TEST="true" # build system adds autotests dir based on BUILD_TESTING value
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
DESCRIPTION="Property editing framework with editor widget similar to Qt Designer"
-[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+HOMEPAGE="https://community.kde.org/KProperty"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+ KEYWORDS="amd64 x86"
+fi
LICENSE="LGPL-2+"
SLOT="5/4"
-KEYWORDS="amd64 x86"
-IUSE=""
DEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kguiaddons)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
"
RDEPEND="${DEPEND}"