summaryrefslogtreecommitdiff
path: root/dev-libs/keystone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/keystone
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/keystone')
-rw-r--r--dev-libs/keystone/Manifest4
-rw-r--r--dev-libs/keystone/keystone-0.9.1.ebuild84
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild81
-rw-r--r--dev-libs/keystone/metadata.xml15
4 files changed, 184 insertions, 0 deletions
diff --git a/dev-libs/keystone/Manifest b/dev-libs/keystone/Manifest
new file mode 100644
index 000000000000..c1a609ff4bb0
--- /dev/null
+++ b/dev-libs/keystone/Manifest
@@ -0,0 +1,4 @@
+DIST keystone-0.9.1.tar.gz 4326151 BLAKE2B 2d41388f4beeff3c424386c77cb75eeca613c66f80e807035f709822f241ef74f64085260678772580cb82bcceda83b4b3c31b92393f8d70f24d54f77f7ba224 SHA512 3bd9c3793d5862a0a8628b52da381625e62445f661dbd5ed715723e7d9db01ce3f9586e5ca0a5cc71e8ceb6c912050f5c28e3ccd540e72c8abcfd2f0d1bbae17
+EBUILD keystone-0.9.1.ebuild 1756 BLAKE2B 41dfdc5d1d23fdb9d1cc53d219a768e941216c308d43bd0274d9089f8bd93d4e84d5c825bc7a94ef984a3ad3df6f1666c78cab11eed0303f82e2bbcb00db9706 SHA512 bceb2c00391b7d7f3889f42f2eeb0ff8aef5fc49843710141b6f3d3c66255f9a2fa090b476f595a24624a85a07e003e4eb9e5edf33a2ec7614c2bb5860e4acf9
+EBUILD keystone-9999.ebuild 1727 BLAKE2B dab4499cf878c8fc38b52f9e8ddb6db77b346056e105bf45048236c4ec4a500a31c0d731dd84dc64618f14aa6edde62d9ce8cc5e02adb1c7f8d935f0be2a7b7f SHA512 30b00a81d8dcec730b9f03f7d882a204a6dcb12c2c8efae7ec4b8e1a89909ade5ea840ed23cc4739ef220bb2b226a72ea2671d3ff681e0c83078c4147fc0bdcd
+MISC metadata.xml 464 BLAKE2B c4a2f085ab1343377cc2f2579511924578e22d74b1204ed517e8cebfd163455b36bae21cf6454ae5a723b52d50a7fb228db363f38d0de032ab1ee5e84c6ccaf1 SHA512 b1b21373ba08d12d1e6508dc7aea5f65922436cd71eb864f20da08214e93d419a181da6af4a59397e632cdd27d279efaaac3bdf91e28c1b6145f61fdf2ae4490
diff --git a/dev-libs/keystone/keystone-0.9.1.ebuild b/dev-libs/keystone/keystone-0.9.1.ebuild
new file mode 100644
index 000000000000..58dfd226f042
--- /dev/null
+++ b/dev-libs/keystone/keystone-0.9.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+CMAKE_MIN_VERSION=3.8.7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils distutils-r1 llvm
+
+DESCRIPTION="assembly/assembler framework + bindings"
+HOMEPAGE="http://www.keystone-engine.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/keystone-engine/keystone.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/keystone-engine/keystone/archive/${PV/_rc/-rc}.tar.gz -> ${P/-rc/_rc}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Keep in sync with llvm/CMakeLists.txt, subset of sys-devel/llvm
+ALL_LLVM_TARGETS=( AArch64 ARM Hexagon Mips PowerPC Sparc SystemZ X86 )
+ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
+LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
+
+IUSE="python ${ALL_LLVM_TARGETS[*]}"
+RDEPEND="${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( ${ALL_LLVM_TARGETS[*]} )
+"
+
+S=${WORKDIR}/${P/_rc/-rc}
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+llvm_check_deps() {
+ has_version "sys-devel/llvm:${LLVM_SLOT}[${LLVM_TARGET_USEDEPS// /,}]"
+}
+
+wrap_python() {
+ if use python; then
+ pushd bindings/python >/dev/null || die
+ distutils-r1_${EBUILD_PHASE_FUNC} "$@"
+ popd >/dev/null || die
+ fi
+}
+
+src_prepare() {
+ default
+ cmake-utils_src_prepare
+ wrap_python
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+ -DBUILD_SHARED_LIBS=ON
+ -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_HOST_TRIPLE="${CHOST}"
+ )
+
+ cmake-utils_src_configure
+ wrap_python
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ wrap_python
+}
+
+src_install() {
+ cmake-utils_src_install
+ wrap_python
+}
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
new file mode 100644
index 000000000000..f3f700fb6607
--- /dev/null
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+CMAKE_MIN_VERSION=3.8.7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils distutils-r1
+
+DESCRIPTION="assembly/assembler framework + bindings"
+HOMEPAGE="http://www.keystone-engine.org/"
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/keystone-engine/keystone.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/keystone-engine/keystone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Keep in sync with llvm/CMakeLists.txt, subset of sys-devel/llvm
+ALL_LLVM_TARGETS=( AArch64 ARM Hexagon Mips PowerPC Sparc SystemZ X86 )
+ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
+LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
+
+IUSE="python ${ALL_LLVM_TARGETS[*]}"
+RDEPEND="sys-devel/llvm:=[${LLVM_TARGET_USEDEPS// /,}]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( ${ALL_LLVM_TARGETS[*]} )
+"
+
+S=${WORKDIR}/${P/_rc/-rc}
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+wrap_python() {
+ if use python; then
+ pushd bindings/python >/dev/null || die
+ distutils-r1_${1} "$@"
+ popd >/dev/null || die
+ fi
+}
+
+src_prepare() {
+ default
+ cmake-utils_src_prepare
+ wrap_python ${FUNCNAME}
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+ -DBUILD_SHARED_LIBS=ON
+ -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_HOST_TRIPLE="${CHOST}"
+ )
+
+ cmake-utils_src_configure
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ cmake-utils_src_install
+ wrap_python ${FUNCNAME}
+}
diff --git a/dev-libs/keystone/metadata.xml b/dev-libs/keystone/metadata.xml
new file mode 100644
index 000000000000..4283547f970d
--- /dev/null
+++ b/dev-libs/keystone/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nemunaire@nemunai.re</email>
+ <name>Pierre-Olivier Mercier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keystone-engine/keystone</remote-id>
+ </upstream>
+</pkgmetadata>