summaryrefslogtreecommitdiff
path: root/dev-libs/keystone/keystone-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-libs/keystone/keystone-9999.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-libs/keystone/keystone-9999.ebuild')
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index 7ef25cfa1b43..c0221f1ff7a7 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-LLVM_MAX_SLOT=12
+LLVM_MAX_SLOT=14
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{8,9,10} )
@@ -19,6 +19,7 @@ else
SRC_URI="https://github.com/keystone-engine/keystone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
fi
+S="${WORKDIR}"/${P/_rc/-rc}
LICENSE="GPL-2"
SLOT="0"
@@ -41,8 +42,6 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"
-S=${WORKDIR}/${P/_rc/-rc}
-
wrap_python() {
if use python; then
pushd bindings/python >/dev/null || die
@@ -53,6 +52,7 @@ wrap_python() {
src_prepare() {
default
+
sed -i '/NOT uppercase_CMAKE_BUILD_TYPE MATCHES/ s/DEBUG/GENTOO|DEBUG/' \
llvm/CMakeLists.txt || die
cmake_src_prepare