summaryrefslogtreecommitdiff
path: root/dev-libs/keystone/keystone-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
commitb392cbf078526e18db5d54ec37f9580be480fd48 (patch)
treef2f8f60717bb0fbe3df7452c2e0b1e0c192341d1 /dev-libs/keystone/keystone-9999.ebuild
parentcd40bc9ab405aca4e72f869db79d9d1ff77d8313 (diff)
gentoo auto-resync : 13:08:2022 - 14:24:01
Diffstat (limited to 'dev-libs/keystone/keystone-9999.ebuild')
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index c0221f1ff7a7..f54ae624af81 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LLVM_MAX_SLOT=14
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake distutils-r1 llvm
@@ -37,11 +37,16 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+RESTRICT=test # only regression tests
+
REQUIRED_USE="
|| ( ${ALL_LLVM_TARGETS[*]} )
python? ( ${PYTHON_REQUIRED_USE} )
"
+# Upstream doesn't flag patch releases (bug 858395)
+QA_PKGCONFIG_VERSION="$(ver_cut 1-2)"
+
wrap_python() {
if use python; then
pushd bindings/python >/dev/null || die