summaryrefslogtreecommitdiff
path: root/dev-libs/keybinder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/keybinder
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/keybinder')
-rw-r--r--dev-libs/keybinder/Manifest5
-rw-r--r--dev-libs/keybinder/keybinder-0.3.1-r201.ebuild50
-rw-r--r--dev-libs/keybinder/keybinder-0.3.2-r300.ebuild45
-rw-r--r--dev-libs/keybinder/metadata.xml11
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-libs/keybinder/Manifest b/dev-libs/keybinder/Manifest
new file mode 100644
index 000000000000..a346b1fbe8e0
--- /dev/null
+++ b/dev-libs/keybinder/Manifest
@@ -0,0 +1,5 @@
+DIST keybinder-0.3.1.tar.gz 391730 BLAKE2B ea286ab5bbd864709a1290ffd8d7d45468b1d525b4fdb8967159bbcf32ca8dc3d057ba39ad35dc19f5f68f67160fc48d805e107fcaea22f81fdd8bd1125db908 SHA512 aec4070b3d3b6c00900c3cb814e4b6a98beea09817eba3c3f7e6d5ce1ff68c091d183583f09b475e3e56bac67c94c1d912ebbe079dcece8195ac0ed9379d5f82
+DIST keybinder-3.0-0.3.2.tar.gz 378942 BLAKE2B f998430a14e881b5b1802747ec15967d60bedf8e076e5ace886a665ad168eb297679f30289b6cae835f4b291a0744c12331e420dcafbfca7e63cc5e807e9cd46 SHA512 14171875e03ade88165f28c7267b66cf9efe34259d7a3072a786ba49dacf8f8d6d84753b1aeedec5dfb0a24028be86bceeebee2f6b1bf5ef2eb79ee45f909b11
+EBUILD keybinder-0.3.1-r201.ebuild 1192 BLAKE2B abcfd749a63275c6f5fa3ec967da4db45327f50bc9093b3e6a9da16171e51fce1b519ee4165582fb10a455a9c0f315b95846127055e480d2f683743d581467d2 SHA512 7c0ff3a1e6f3d51fc6874234757e8c66d16356eeb14a8657dc51232a694b54b878532c168116aff0e3f6871006b96ee6c784d523541b51a97a76dc4b5b1c871f
+EBUILD keybinder-0.3.2-r300.ebuild 1051 BLAKE2B cb4e876eb83fa674d598dd06045c795d0a562a5c212fc9685af67b74f473399238d213338d6874703092527b6257e0c06be24910833b8c4d8d0d9fdbf7a20069 SHA512 e3938b72869e319c940ed2392d60aeb6b27aeb8344065f845678fc95e80169362de1a3efdbb1264407c26ea55333048298b45e5c283393b0749d56838b748e91
+MISC metadata.xml 327 BLAKE2B 61157058cd32bae91e1b8bbae3235e70fd34ec1c6f89af874e974e76e5daba3ddb9b34878271d96a4ac761126b3d596f257014f24d40130256a2fcfa491f86d1 SHA512 e2597d9b1771b6cc57c5b372c5fa3a5a51cea3e87bbe3aaee10eae1fd90c445859eca6f855eb34f079253da6a771a747257ffe8b3b1834597791c03b7d3752f8
diff --git a/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild b/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
new file mode 100644
index 000000000000..e081ae83d7f7
--- /dev/null
+++ b/dev-libs/keybinder/keybinder-0.3.1-r201.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="A library for registering global keyboard shortcuts"
+HOMEPAGE="https://github.com/engla/keybinder"
+SRC_URI="https://github.com/engla/keybinder/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 x86"
+IUSE="+introspection lua python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ introspection? ( dev-libs/gobject-introspection )
+ lua? ( >=dev-lang/lua-5.1 )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.3:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable python)
+ )
+ # upstream failed at AC_ARG_ENABLE
+ use lua || myconf+=( --disable-lua )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild b/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild
new file mode 100644
index 000000000000..de5cd8598a0a
--- /dev/null
+++ b/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${PN}-3.0-${PV}
+DESCRIPTION="A library for registering global keyboard shortcuts"
+HOMEPAGE="https://github.com/engla/keybinder"
+SRC_URI="https://github.com/engla/keybinder/releases/download/${PN}-3.0-v${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 x86"
+IUSE="+introspection"
+
+RDEPEND="x11-libs/gtk+:3[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ # remove old symlink as otherwise the files will be installed
+ # in the wrong directory
+ if [[ -h ${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0 ]]; then
+ rm "${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0" || die
+ fi
+}
diff --git a/dev-libs/keybinder/metadata.xml b/dev-libs/keybinder/metadata.xml
new file mode 100644
index 000000000000..c363c085d028
--- /dev/null
+++ b/dev-libs/keybinder/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">engla/keybinder</remote-id>
+ </upstream>
+</pkgmetadata>