summaryrefslogtreecommitdiff
path: root/dev-libs/judy/judy-1.0.5-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-libs/judy/judy-1.0.5-r3.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-libs/judy/judy-1.0.5-r3.ebuild')
-rw-r--r--dev-libs/judy/judy-1.0.5-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/judy/judy-1.0.5-r3.ebuild b/dev-libs/judy/judy-1.0.5-r3.ebuild
new file mode 100644
index 000000000000..3c9b879d9d3d
--- /dev/null
+++ b/dev-libs/judy/judy-1.0.5-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="A C library that implements a dynamic array"
+HOMEPAGE="http://judy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/judy/Judy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}-parallel-make.patch"
+ eapply "${FILESDIR}/${P}-gcc49.patch"
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ eapply_user
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${BUILD_DIR} econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all(){
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}