summaryrefslogtreecommitdiff
path: root/dev-libs/ivykis/ivykis-0.43.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
commit4464bf26d93bdcc80e0b1330fe9c9caef26b34fc (patch)
tree62f9e9438bf700cf277191db5d7c3a641bc972dc /dev-libs/ivykis/ivykis-0.43.ebuild
parent8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (diff)
gentoo auto-resync : 09:03:2024 - 01:07:53
Diffstat (limited to 'dev-libs/ivykis/ivykis-0.43.ebuild')
-rw-r--r--dev-libs/ivykis/ivykis-0.43.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/ivykis/ivykis-0.43.ebuild b/dev-libs/ivykis/ivykis-0.43.ebuild
new file mode 100644
index 000000000000..8123da4967da
--- /dev/null
+++ b/dev-libs/ivykis/ivykis-0.43.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for asynchronous I/O readiness notification"
+HOMEPAGE="https://github.com/buytenh/ivykis"
+SRC_URI="https://github.com/buytenh/ivykis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --cache-file="${S}"/config.cache \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+}