summaryrefslogtreecommitdiff
path: root/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-libs/intel-neo/intel-neo-20.10.16087.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-libs/intel-neo/intel-neo-20.10.16087.ebuild')
-rw-r--r--dev-libs/intel-neo/intel-neo-20.10.16087.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild b/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild
new file mode 100644
index 000000000000..cebb0b1a0ca1
--- /dev/null
+++ b/dev-libs/intel-neo/intel-neo-20.10.16087.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON=">=virtual/opencl-3
+ >=dev-util/intel-graphics-compiler-1.0.3445
+ >=media-libs/gmmlib-19.4.1
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )"
+DEPEND="${COMMON}
+ media-libs/mesa" # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+ README.md
+ FAQ.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+ -DDISABLE_LIBVA=$(usex vaapi "OFF" "ON")
+ # If enabled, tests are automatically run during the compile phase
+ # - and we cannot run them because they require permissions to access
+ # the hardware.
+ -DSKIP_UNIT_TESTS=ON
+ )
+ cmake_src_configure
+}