summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild')
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
index 4b6c563cdd2a..fb7f4bdf494f 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
@@ -7,7 +7,7 @@ CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
HOMEPAGE="https://github.com/intel/compute-runtime"
@@ -44,6 +44,9 @@ DOCS=( "README.md" "FAQ.md" )
PATCHES=( "${FILESDIR}/${PN}-22.12.22749-metrics.patch" )
src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_LIBDIR="$(get_libdir)"