summaryrefslogtreecommitdiff
path: root/dev-libs/input-pad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/input-pad
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/input-pad')
-rw-r--r--dev-libs/input-pad/Manifest3
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild52
-rw-r--r--dev-libs/input-pad/metadata.xml15
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/input-pad/Manifest b/dev-libs/input-pad/Manifest
new file mode 100644
index 000000000000..56d0d6098c30
--- /dev/null
+++ b/dev-libs/input-pad/Manifest
@@ -0,0 +1,3 @@
+DIST input-pad-1.0.99.20140916.tar.gz 621070 SHA256 e0769e5e6fe4d741d25189ebe98dbf0f9d7edc1a516025783c0574799684159c SHA512 a7dd7996f69dbb6cc200be3c181e82ef8d701f85f1b27a886a8910afb3e673c1d71878e70b79141570a28a31dd47565868a990a358058ae8b99c29c76a316261 WHIRLPOOL d6121617a31f864e622cc02007faa033a1e0357760543f3b30dee064fb9b16867a0d366a062df313677ede74831f39a386eada85dcd1a1f32f03599191f033da
+EBUILD input-pad-1.0.99_pre20140916.ebuild 1098 SHA256 c63133298a6e50f44510ca309fe9848e4812e761e670a58e109b59af10526816 SHA512 18a9a03a3f626e2135096ebda56ae3303ab5d1efb2e4b653ff53f95efea421e8be9bcef80997124afd7c4323f58581d627d221b34b0da2efcb30c627edbd0097 WHIRLPOOL baa119b184dd7faebcaf57aea265cd5545d0ae2f85c464b2cd9945d06e744b268fb1430d659c06207e8cb2ce85d40739d03b678f56b3d6f9aca560b52369a95c
+MISC metadata.xml 503 SHA256 7863eba495e11973788d89a793dbaa09315b26eb8109c933bdbbfef0433fef85 SHA512 da6ac24e8d5e575dadabe7e11c128203b8ee16b72297569cf5c3e8071ef85a297bad2b9c1ec634c27909cf88e051bc4f73dc1fb24070ed5789a05bcfd913ce35 WHIRLPOOL 9441bb1d6aae19bc876b8f79f889553dc4744625bc7ee66fd88d669bdcc5d11809a697e267d680149fadb61d4bf3b9a19676ba9833a8337be23944ebe1b3e269
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
new file mode 100644
index 000000000000..f884a5d7fb2b
--- /dev/null
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune xdg-utils
+
+MY_P="${P/_pre/.}"
+MY_PV="${PV/_pre/.}"
+
+DESCRIPTION="On-screen input pad to send characters with mouse"
+HOMEPAGE="https://github.com/fujiwarat/input-pad/wiki"
+SRC_URI="https://github.com/fujiwarat/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eekboard +introspection static-libs +xtest"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libxklavier
+ virtual/libintl
+ eekboard? ( dev-libs/eekboard )
+ introspection? ( dev-libs/gobject-introspection )
+ xtest? ( x11-libs/libXtst )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable eekboard eek) \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable xtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/input-pad/metadata.xml b/dev-libs/input-pad/metadata.xml
new file mode 100644
index 000000000000..fc144ccafd3d
--- /dev/null
+++ b/dev-libs/input-pad/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="eekboard">Enable support for <pkg>dev-libs/eekboard</pkg></flag>
+ <flag name="xtest">Enable support for <pkg>x11-libs/libXtst</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">fujiwarat/input-pad</remote-id>
+ </upstream>
+</pkgmetadata>