summaryrefslogtreecommitdiff
path: root/dev-libs/iniparser/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/iniparser/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/iniparser/files')
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0-autotools.patch38
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0b-cpp.patch47
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
deleted file mode 100644
index 89c7f63d29af..000000000000
--- a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- /dev/null
-+++ Makefile.am
-@@ -0,0 +1,8 @@
-+ACLOCAL_AMFLAGS = -I config
-+
-+lib_LTLIBRARIES = libiniparser.la
-+
-+libiniparser_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
-+libiniparser_la_SOURCES = src/dictionary.c src/iniparser.c
-+
-+include_HEADERS = src/dictionary.h src/iniparser.h
---- /dev/null
-+++ configure.ac
-@@ -0,0 +1,24 @@
-+AC_PREREQ([2.65])
-+AC_INIT([iniparser], [3.0], [ndevilla@free.fr])
-+
-+AC_CONFIG_AUX_DIR(config)
-+AC_CONFIG_MACRO_DIR(config)
-+
-+AM_INIT_AUTOMAKE([1.8 foreign])
-+
-+SHARED_VERSION_INFO="0"
-+AC_SUBST(SHARED_VERSION_INFO)
-+
-+# Checks for programs.
-+AC_PROG_CC
-+AC_SYS_LARGEFILE
-+
-+LT_INIT
-+# Checks for header files.
-+AC_CHECK_HEADERS([ ctype.h stdio.h stdlib.h string.h ])
-+
-+# Checks for library functions.
-+AC_CHECK_FUNCS([strcmp])
-+
-+AC_CONFIG_FILES([Makefile])
-+AC_OUTPUT
diff --git a/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch b/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
deleted file mode 100644
index cb331b813093..000000000000
--- a/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -ur iniparser3.0b/src/dictionary.c iniparser3.0b-patched/src/dictionary.c
---- iniparser3.0b/src/dictionary.c 2007-11-24 05:39:18.000000000 +0800
-+++ iniparser3.0b-patched/src/dictionary.c 2009-04-01 21:38:09.000000000 +0800
-@@ -38,6 +38,9 @@
- /*---------------------------------------------------------------------------
- Private functions
- ---------------------------------------------------------------------------*/
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-
- /* Doubles the allocated size associated to a pointer */
- /* 'size' is the current allocated size. */
-@@ -401,5 +404,10 @@
- dictionary_del(d);
- return 0 ;
- }
-+
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif
- /* vim: set ts=4 et sw=4 tw=75 */
-diff -ur iniparser3.0b/src/iniparser.h iniparser3.0b-patched/src/iniparser.h
---- iniparser3.0b/src/iniparser.h 2007-11-24 05:38:19.000000000 +0800
-+++ iniparser3.0b-patched/src/iniparser.h 2009-04-01 21:38:02.000000000 +0800
-@@ -41,6 +41,10 @@
- #define iniparser_getstr(d, k) iniparser_getstring(d, k, NULL)
- #define iniparser_setstr iniparser_setstring
-
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-+
- /*-------------------------------------------------------------------------*/
- /**
- @brief Get number of sections in a dictionary
-@@ -277,4 +281,8 @@
- /*--------------------------------------------------------------------------*/
- void iniparser_freedict(dictionary * d);
-
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif