summaryrefslogtreecommitdiff
path: root/dev-libs/iniparser/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-libs/iniparser/files
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-libs/iniparser/files')
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0-autotools.patch4
-rw-r--r--dev-libs/iniparser/files/iniparser-3.0b-cpp.patch30
-rw-r--r--dev-libs/iniparser/files/iniparser-4.0-out-of-bounds-read.patch15
3 files changed, 18 insertions, 31 deletions
diff --git a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
index 89c7f63d29af..361c96a7d4fb 100644
--- a/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
+++ b/dev-libs/iniparser/files/iniparser-3.0-autotools.patch
@@ -1,5 +1,5 @@
--- /dev/null
-+++ Makefile.am
++++ b/Makefile.am
@@ -0,0 +1,8 @@
+ACLOCAL_AMFLAGS = -I config
+
@@ -10,7 +10,7 @@
+
+include_HEADERS = src/dictionary.h src/iniparser.h
--- /dev/null
-+++ configure.ac
++++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_PREREQ([2.65])
+AC_INIT([iniparser], [3.0], [ndevilla@free.fr])
diff --git a/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch b/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
index cb331b813093..b7cd17d2d226 100644
--- a/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
+++ b/dev-libs/iniparser/files/iniparser-3.0b-cpp.patch
@@ -1,9 +1,8 @@
-diff -ur iniparser3.0b/src/dictionary.c iniparser3.0b-patched/src/dictionary.c
---- iniparser3.0b/src/dictionary.c 2007-11-24 05:39:18.000000000 +0800
-+++ iniparser3.0b-patched/src/dictionary.c 2009-04-01 21:38:09.000000000 +0800
-@@ -38,6 +38,9 @@
+--- a/src/dictionary.c
++++ b/src/dictionary.c
+@@ -32,6 +32,9 @@
/*---------------------------------------------------------------------------
- Private functions
+ Private functions
---------------------------------------------------------------------------*/
+#ifdef __cplusplus
+extern "C" {
@@ -11,9 +10,9 @@ diff -ur iniparser3.0b/src/dictionary.c iniparser3.0b-patched/src/dictionary.c
/* Doubles the allocated size associated to a pointer */
/* 'size' is the current allocated size. */
-@@ -401,5 +404,10 @@
- dictionary_del(d);
- return 0 ;
+@@ -394,5 +397,10 @@
+ dictionary_del(d);
+ return 0 ;
}
+
+#ifdef __cplusplus
@@ -22,12 +21,11 @@ diff -ur iniparser3.0b/src/dictionary.c iniparser3.0b-patched/src/dictionary.c
+
#endif
/* vim: set ts=4 et sw=4 tw=75 */
-diff -ur iniparser3.0b/src/iniparser.h iniparser3.0b-patched/src/iniparser.h
---- iniparser3.0b/src/iniparser.h 2007-11-24 05:38:19.000000000 +0800
-+++ iniparser3.0b-patched/src/iniparser.h 2009-04-01 21:38:02.000000000 +0800
-@@ -41,6 +41,10 @@
- #define iniparser_getstr(d, k) iniparser_getstring(d, k, NULL)
- #define iniparser_setstr iniparser_setstring
+--- a/src/iniparser.h
++++ b/src/iniparser.h
+@@ -49,6 +49,10 @@
+ int iniparser_getnsec(dictionary * d);
+
+#ifdef __cplusplus
+extern "C" {
@@ -35,8 +33,8 @@ diff -ur iniparser3.0b/src/iniparser.h iniparser3.0b-patched/src/iniparser.h
+
/*-------------------------------------------------------------------------*/
/**
- @brief Get number of sections in a dictionary
-@@ -277,4 +281,8 @@
+ @brief Get name for section n in a dictionary.
+@@ -304,4 +308,8 @@
/*--------------------------------------------------------------------------*/
void iniparser_freedict(dictionary * d);
diff --git a/dev-libs/iniparser/files/iniparser-4.0-out-of-bounds-read.patch b/dev-libs/iniparser/files/iniparser-4.0-out-of-bounds-read.patch
index 962566cd5b7f..f6488810ac12 100644
--- a/dev-libs/iniparser/files/iniparser-4.0-out-of-bounds-read.patch
+++ b/dev-libs/iniparser/files/iniparser-4.0-out-of-bounds-read.patch
@@ -1,17 +1,6 @@
-From 4f870752abbb756911d7b11405d49e9769d082bd Mon Sep 17 00:00:00 2001
-From: Emmanuel Leblond <emmanuel.leblond@gmail.com>
-Date: Fri, 8 Apr 2016 22:13:36 +0200
-Subject: [PATCH] Fix #68 when reading file with only \0 char
-
----
- src/iniparser.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/iniparser.c b/src/iniparser.c
-index be37fec..fb1b549 100644
--- a/src/iniparser.c
+++ b/src/iniparser.c
-@@ -678,7 +678,7 @@ dictionary * iniparser_load(const char * ininame)
+@@ -663,7 +663,7 @@
while (fgets(line+last, ASCIILINESZ-last, in)!=NULL) {
lineno++ ;
len = (int)strlen(line)-1;
@@ -19,4 +8,4 @@ index be37fec..fb1b549 100644
+ if (len<=0)
continue;
/* Safety check against buffer overflows */
- if (line[len]!='\n' && !feof(in)) {
+ if (line[len]!='\n') {