summaryrefslogtreecommitdiff
path: root/dev-libs/inih/inih-58.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 12:56:47 +0000
commit4482d99f0743195c71b2b03faa8bfbda5501910b (patch)
tree853f042c5e26ca4bce5b091ccc3128b9a763984a /dev-libs/inih/inih-58.ebuild
parent9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (diff)
gentoo auto-resync : 27:01:2024 - 12:56:47
Diffstat (limited to 'dev-libs/inih/inih-58.ebuild')
-rw-r--r--dev-libs/inih/inih-58.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-58.ebuild b/dev-libs/inih/inih-58.ebuild
new file mode 100644
index 000000000000..6793c8255fc4
--- /dev/null
+++ b/dev-libs/inih/inih-58.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson-multilib
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/inih-r${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DOCS=( README.md )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson-multilib_src_configure
+}