summaryrefslogtreecommitdiff
path: root/dev-libs/igraph/igraph-0.10.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
commit72d7e048ae88be323a380e2eae52dfda0b2dc1c0 (patch)
treee3d45f3a557c324e6058aae95f920e55d8f40602 /dev-libs/igraph/igraph-0.10.4-r1.ebuild
parent8b4349b75818953123e2d4b80963181a9640c8e3 (diff)
gentoo auto-resync : 11:03:2024 - 18:45:56
Diffstat (limited to 'dev-libs/igraph/igraph-0.10.4-r1.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.10.4-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/igraph/igraph-0.10.4-r1.ebuild b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
index 0020face7f80..fd9d1d6f77ec 100644
--- a/dev-libs/igraph/igraph-0.10.4-r1.ebuild
+++ b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Creating and manipulating undirected and directed graphs"
HOMEPAGE="https://igraph.org/"
@@ -27,6 +27,12 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing
+ #
+ # Fixed in upstream git master.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_CCACHE=OFF
-DIGRAPH_GLPK_SUPPORT=ON