summaryrefslogtreecommitdiff
path: root/dev-libs/igraph/igraph-0.10.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
commit24c53d42e0294f4f6e36fbb051891af86c9ae503 (patch)
treeb0af743b9df96807807fc6a16e77af239820b0c3 /dev-libs/igraph/igraph-0.10.4-r1.ebuild
parent351b26cfd42c558fa0f8eef51960c87bb0674026 (diff)
gentoo auto-resync : 23:05:2023 - 02:57:53
Diffstat (limited to 'dev-libs/igraph/igraph-0.10.4-r1.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.10.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/igraph/igraph-0.10.4-r1.ebuild b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
new file mode 100644
index 000000000000..55e82ab3fb68
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="https://igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-mathematics/glpk:=
+ sci-mathematics/plfit
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_USE_INTERNAL_PLFIT=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}