summaryrefslogtreecommitdiff
path: root/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild')
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
new file mode 100644
index 000000000000..f6029e446bf0
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="http://www.harfbuzz.org https://github.com/behdad/icu-le-hb"
+SRC_URI="https://github.com/behdad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+# dev-libs/icu is not linked into icu-le-hb but the latter still needs
+# to be rebuilt on dev-libs/icu upgrades (see bug #621786).
+RDEPEND="
+ >=dev-libs/icu-58.1:=[${MULTILIB_USEDEP}]
+ media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}