summaryrefslogtreecommitdiff
path: root/dev-libs/hyphen/hyphen-2.8.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
commit1d18b53ed419c49eb3f71637ccd58a431c1368d4 (patch)
treeeb3671b1209855aa64534ee96262d06bcda99d74 /dev-libs/hyphen/hyphen-2.8.8-r2.ebuild
parentfdca6388cf31827202fae75cae067c695bd09339 (diff)
gentoo auto-resync : 14:04:2023 - 05:44:49
Diffstat (limited to 'dev-libs/hyphen/hyphen-2.8.8-r2.ebuild')
-rw-r--r--dev-libs/hyphen/hyphen-2.8.8-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/hyphen/hyphen-2.8.8-r2.ebuild b/dev-libs/hyphen/hyphen-2.8.8-r2.ebuild
new file mode 100644
index 000000000000..f53aaa413168
--- /dev/null
+++ b/dev-libs/hyphen/hyphen-2.8.8-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="ALTLinux hyphenation library"
+HOMEPAGE="https://hunspell.github.io/"
+SRC_URI="mirror://sourceforge/hunspell/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="app-text/hunspell"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-lang/perl"
+
+DOCS=( AUTHORS ChangeLog NEWS README{,.nonstandard,.hyphen,.compound} THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mawk.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ rm -r "${ED}"/usr/share/hyphen || die
+ # bug #775587
+ rm -f "${ED}/usr/$(get_libdir)/libhyphen.la" || die
+}