summaryrefslogtreecommitdiff
path: root/dev-libs/hidapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/hidapi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/hidapi')
-rw-r--r--dev-libs/hidapi/Manifest3
-rw-r--r--dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild75
-rw-r--r--dev-libs/hidapi/metadata.xml22
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/hidapi/Manifest b/dev-libs/hidapi/Manifest
new file mode 100644
index 000000000000..91bb65ecb509
--- /dev/null
+++ b/dev-libs/hidapi/Manifest
@@ -0,0 +1,3 @@
+DIST hidapi-0.8.0_rc1_p20140719.tgz 103079 BLAKE2B f40a4c17cb8c5eed41f4eea84fac46a879ec2057f28212aa43c8fd718ceea68d760785cb4f4e2ea3bcd2a4345b65d75d0d278b93697ec61963be9270684a15cb SHA512 204934a707da4e67b834823650b0cfd9be7b413972071129cc5aeeb93465834dde2f5ee23283c55d35b56e3aed8b7ad5fe947399839081f4d895fb65c8cd3e3d
+EBUILD hidapi-0.8.0_rc1_p20140719.ebuild 1918 BLAKE2B 0826282d68d25e30586c315329b4dd43e8dbf2c2d0da5f01101d363b4cc41594440c0881b34a9cd7278ad82feefc6bfb8b85cc8d6c16e37995bed816dabf9319 SHA512 e3a4c5bc1767491641b6249f2552790f6e27aeb8309c3435ee29fbcfdfef483c2b550c54fd2e6d1ee24ecff0e10f10813e78606fb11e9ea75367511bddeaec3b
+MISC metadata.xml 659 BLAKE2B cb156ee4a06d9725266e45fca2f085b74d6cf09e8f97a99a59961b2977f44669720ff15213ad84bcba95dd62df0f876d3a2fc75eb4e006e86a1baddd44c5d0c2 SHA512 36bae2c3d3cb19327990c2df04a591d77ee8a8d5f0b269b636902156e2e8315e00fbad6f1f8fac9776598b42423f4ab626ee8b576b897ad5b92ef7d2f3081e58
diff --git a/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild
new file mode 100644
index 000000000000..9cefcad3a4c8
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit eutils versionator autotools-multilib #git-2
+
+# If github is desired, the following may be used.
+#EGIT_REPO_URI="https://github.com/signal11/hidapi.git"
+#EGIT_BRANCH="master"
+EGIT_COMMIT="d17db57b9d4354752e0af42f5f33007a42ef2906"
+
+# S is only needed for the debian_package
+S=${WORKDIR}/${PN}-${DEBIAN_PV}
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="http://www.signal11.us/oss/hidapi/"
+SRC_URI="https://github.com/signal11/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tgz"
+# When 0.8.0 is officially available the following link should be used.
+#SRC_URI="mirror://github/signal11/${PN}/${P}.zip"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="doc fox static-libs"
+
+RDEPEND="virtual/libusb:1[${MULTILIB_USEDEP}]
+ virtual/libudev:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ fox? ( x11-libs/fox )"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ if ! use fox; then
+ sed -i -e 's:PKG_CHECK_MODULES(\[fox\], .*):AC_SUBST(fox_CFLAGS,[ ])AC_SUBST(fox_LIBS,[ ]):' configure.ac || die
+ fi
+
+ # Fix bashisms in the configure.ac file.
+ sed -i -e 's:\([A-Z_]\+\)+="\(.*\)":\1="${\1}\2":g' \
+ -e 's:\([A-Z_]\+\)+=`\(.*\)`:\1="${\1}\2":g' configure.ac || die
+
+ # Portage handles license texts itself, no need to install them
+ sed -i -e 's/LICENSE.*/ # blank/' Makefile.am || die
+
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(multilib_native_use_enable fox testgui)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-multilib_src_compile
+
+ if use doc; then
+ doxygen doxygen/Doxyfile || die
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc; then
+ dohtml -r html/.
+ fi
+}
diff --git a/dev-libs/hidapi/metadata.xml b/dev-libs/hidapi/metadata.xml
new file mode 100644
index 000000000000..d5b410c9655d
--- /dev/null
+++ b/dev-libs/hidapi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="fox">Build a x11-libs/fox GUI</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">signal11/hidapi</remote-id>
+ </upstream>
+</pkgmetadata>