summaryrefslogtreecommitdiff
path: root/dev-libs/hidapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-libs/hidapi
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-libs/hidapi')
-rw-r--r--dev-libs/hidapi/Manifest1
-rw-r--r--dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719-r1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/hidapi/Manifest b/dev-libs/hidapi/Manifest
index 504efb5ecc97..29a8d1d25032 100644
--- a/dev-libs/hidapi/Manifest
+++ b/dev-libs/hidapi/Manifest
@@ -1,4 +1,5 @@
AUX hidapi-0.8.0_rc1_p20140719-autoconf-2.70.patch 300 BLAKE2B f82fe6a6e2ebfda10eb9762bbff1586346ecf8945996599a3b58658c37799d85dc573f8be54bba483f95e27177db3f421d99ac713e7012130d2e2b92252ebd87 SHA512 5b29caa5f7a9b61fffb16226cff9709a5b142c6ac36017c567ab5933b21f06cb17c78a93fa19e8c92cb1443f1cbe97c3687002845965bea2b3ef39eeaef1f4a2
DIST hidapi-0.8.0_rc1_p20140719.tgz 103079 BLAKE2B f40a4c17cb8c5eed41f4eea84fac46a879ec2057f28212aa43c8fd718ceea68d760785cb4f4e2ea3bcd2a4345b65d75d0d278b93697ec61963be9270684a15cb SHA512 204934a707da4e67b834823650b0cfd9be7b413972071129cc5aeeb93465834dde2f5ee23283c55d35b56e3aed8b7ad5fe947399839081f4d895fb65c8cd3e3d
+EBUILD hidapi-0.8.0_rc1_p20140719-r1.ebuild 1846 BLAKE2B 114ceec61e90c1ada45c8eb9e5aec9194be98d8ed19306852a48b59812f3805f24cb92902c76dd84cbce338663488b2304aa932102d3b087749bbe6a30a0bcfc SHA512 2bad7544896966bc660d6f392ecfffc1c6f8a24ce883e53019ac69a7a12fc724f24efa70c1acd8712abac3d311a54b2619020f647541e284ed06eb68ed588c01
EBUILD hidapi-0.8.0_rc1_p20140719.ebuild 1985 BLAKE2B 87615eda8dea3490a69324a0d07dea4fc79d0792ff132a6d10b5ee8387e46245b3fbb763eccdb8d8cfbbc6b4ec7c0bd16c411ef5a8afa0e60a9d64d390b00d63 SHA512 7e25765fb19ee59e2877c4155cd0495b82e3548e25b1c15ba8b3d2f58ad22711480c766b96f43e150268ed1fb5745c03184badcff35cfc0e96272767b3af8af5
MISC metadata.xml 540 BLAKE2B 6396197ca946971d1e954233589189f5e91dd4dc4fd6182f5cdf24890a5601a5e32fa71e2f4b2a676d346cb8feb1232467fa569f9348a5b788f5ee4a6838d7dc SHA512 3e0185fa3a56d0bb18f1256fe9e5c74cb5cdaea91cd24054d12243512012fdead25ac69c84a82d282b070bd73be2a9a7e313e858c05e6c2fe49bd38cba4d28d1
diff --git a/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719-r1.ebuild b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719-r1.ebuild
new file mode 100644
index 000000000000..869fc66c0990
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.8.0_rc1_p20140719-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+# If github is desired, the following may be used.
+#EGIT_REPO_URI="https://github.com/signal11/hidapi.git"
+#EGIT_BRANCH="master"
+EGIT_COMMIT="d17db57b9d4354752e0af42f5f33007a42ef2906"
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="http://www.signal11.us/oss/hidapi/"
+SRC_URI="https://github.com/signal11/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tgz"
+# When 0.8.0 is officially available the following link should be used.
+#SRC_URI="https://github.com/downloads/signal11/${PN}/${P}.zip"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc fox"
+
+RDEPEND="
+ virtual/libusb:1[${MULTILIB_USEDEP}]
+ virtual/libudev:0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ fox? ( x11-libs/fox )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${P}-autoconf-2.70.patch )
+
+src_prepare() {
+ default
+
+ if ! use fox; then
+ sed -i -e 's:PKG_CHECK_MODULES(\[fox\], .*):AC_SUBST(fox_CFLAGS,[ ])AC_SUBST(fox_LIBS,[ ]):' configure.ac || die
+ fi
+
+ # Fix bashisms in the configure.ac file.
+ sed -i -e 's:\([A-Z_]\+\)+="\(.*\)":\1="${\1}\2":g' \
+ -e 's:\([A-Z_]\+\)+=`\(.*\)`:\1="${\1}\2":g' configure.ac || die
+
+ # Portage handles license texts itself, no need to install them
+ sed -i -e 's/LICENSE.*/ # blank/' Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(multilib_native_use_enable fox testgui)
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ doxygen doxygen/Doxyfile || die
+ HTML_DOCS=( html/. )
+ fi
+
+ einstalldocs
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}