summaryrefslogtreecommitdiff
path: root/dev-libs/grok/grok-0.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/grok/grok-0.9.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/grok/grok-0.9.2-r1.ebuild')
-rw-r--r--dev-libs/grok/grok-0.9.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/grok/grok-0.9.2-r1.ebuild b/dev-libs/grok/grok-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..967671141eed
--- /dev/null
+++ b/dev-libs/grok/grok-0.9.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="DRY and RAD for regular expressions"
+HOMEPAGE="https://github.com/jordansissel/grok https://code.google.com/p/semicomplete/wiki/Grok"
+SRC_URI="https://github.com/jordansissel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+
+IUSE=""
+
+CDEPEND="dev-db/tokyocabinet
+ >=dev-libs/libevent-1.3:=
+ >=dev-libs/libpcre-7.6"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ >=dev-util/gperf-3.1"
+
+PATCHES=(
+ "${FILESDIR}"/grok-0.9.2-Makefile.patch
+ "${FILESDIR}"/0.9.2-build-with-pcre-lt-8.34.patch
+ "${FILESDIR}"/grok-0.9.2-build-with-gperf-3.1.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}