summaryrefslogtreecommitdiff
path: root/dev-libs/granite/granite-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/granite/granite-6.0.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/granite/granite-6.0.0.ebuild')
-rw-r--r--dev-libs/granite/granite-6.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/granite/granite-6.0.0.ebuild b/dev-libs/granite/granite-6.0.0.ebuild
new file mode 100644
index 000000000000..e63ea67376b0
--- /dev/null
+++ b/dev-libs/granite/granite-6.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION=0.40
+BUILD_DIR="${WORKDIR}/${P}-build"
+
+inherit meson vala xdg
+
+DESCRIPTION="Elementary OS library that extends GTK+"
+HOMEPAGE="https://github.com/elementary/granite"
+SRC_URI="https://github.com/elementary/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ dev-libs/libgee:0.8[introspection]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}
+
+src_configure() {
+ # docs disabled due to: https://github.com/elementary/granite/issues/482
+ local emesonargs=(
+ -Ddocumentation=false
+ )
+ meson_src_configure
+}