summaryrefslogtreecommitdiff
path: root/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-libs/gost-engine/gost-engine-3.0.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-libs/gost-engine/gost-engine-3.0.1.ebuild')
-rw-r--r--dev-libs/gost-engine/gost-engine-3.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/gost-engine/gost-engine-3.0.1.ebuild b/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
new file mode 100644
index 000000000000..b9fc8e721abe
--- /dev/null
+++ b/dev-libs/gost-engine/gost-engine-3.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
+HOMEPAGE="https://github.com/gost-engine/engine"
+IUSE="test"
+RESTRICT="!test? ( test )"
+SLOT="0/${PV}"
+
+COMMON_DEPEND=">=dev-libs/openssl-3.0.0:0="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-lang/perl
+ )"
+RDEPEND="${COMMON_DEPEND}"
+
+LICENSE="openssl"
+
+DOCS=( INSTALL.md README.gost README.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa"
+ SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/engine-${PV}"
+fi
+
+src_prepare() {
+ cmake_src_prepare
+ sed 's:Werror:Wno-error:g' -i "${S}/CMakeLists.txt" || die
+}