summaryrefslogtreecommitdiff
path: root/dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 00:10:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 00:10:03 +0000
commitb256b4b120d8269d4415eac0c354eb603a7bf953 (patch)
tree4a034d19dc148353dd4ed6094848d51387f8b07e /dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild
parent8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (diff)
gentoo auto-resync : 06:01:2023 - 00:10:03
Diffstat (limited to 'dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild')
-rw-r--r--dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild b/dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..892b8bb3cdd6
--- /dev/null
+++ b/dev-libs/gost-engine/gost-engine-3.0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A reference implementation of the Russian GOST crypto algorithms for OpenSSL"
+HOMEPAGE="https://github.com/gost-engine/engine"
+IUSE="test"
+RESTRICT="!test? ( test )"
+SLOT="0/${PV}"
+
+COMMON_DEPEND=">=dev-libs/openssl-3.0.0:0="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-lang/perl
+ )"
+RDEPEND="${COMMON_DEPEND}"
+
+LICENSE="openssl"
+
+DOCS=( INSTALL.md README.gost README.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-cmake-path.patch"
+)
+
+LIBPROV_COMMIT="8a126e09547630ef900177625626b6156052f0ee"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/gost-engine/engine.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~hppa"
+ SRC_URI="https://github.com/gost-engine/engine/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/provider-corner/libprov/archive/${LIBPROV_COMMIT}.tar.gz -> libprov-${LIBPROV_COMMIT}.tar.gz"
+ S="${WORKDIR}/engine-${PV}"
+fi
+
+src_prepare() {
+ cp -R "${WORKDIR}/libprov-${LIBPROV_COMMIT}/." "${S}/libprov" || die
+ cmake_src_prepare
+ sed 's:Werror:Wno-error:g' -i "${S}/CMakeLists.txt" || die
+}