summaryrefslogtreecommitdiff
path: root/dev-libs/gobject-introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/gobject-introspection
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/Manifest2
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.58.3.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
index d31a660d5e82..e761743278f3 100644
--- a/dev-libs/gobject-introspection/Manifest
+++ b/dev-libs/gobject-introspection/Manifest
@@ -1,3 +1,5 @@
DIST gobject-introspection-1.56.1.tar.xz 1397812 BLAKE2B 070597f3bd6e4e58d1ae1964cf6e8d7881daa68aeeddc5e9b64bc410fad6d435f2041171f4dfc2a6b477d39f2d7e9181b9917d1244fcb45b3a37491726381649 SHA512 2bfcd45b8c5ad68a3f6550c2f80a6804db0e1a72ffaf4fdd3cec3d8acc23e79ad14bb5bf612fe26fc896691839ab19ca8dd1c9994db14d730e56fa79df9d973d
+DIST gobject-introspection-1.58.3.tar.xz 1378068 BLAKE2B 3ae0328892da30aeefcfb8f6d343312d4967345cc202ef137f29690fbd7a35fa9310f87b134fbdfd4fd753b68b47203cd306689d9892eccf17e303d1e7bcccd4 SHA512 0811cd08e224975b3aa55ae89d648fc65f3105cae8a077a5671593d84743b1db28e9fbffe53fc86a2b3e82ea98c35f3daae033d3df07c7020cc3bf8b5d94f796
EBUILD gobject-introspection-1.56.1.ebuild 2127 BLAKE2B fd53f7a27db901bf2f0371ea7f63a3e42cfb35889770fe46892ac625afda5d5fa9ccebf3d066ae0582016baa2ef68efd8974fbe9d223a73d1d178a79c4e228f5 SHA512 cd5053739873a7313aac796efa96cb0bdd0ea6baffc9030250aa9929ede954315206dbc8dc7f21b05a6bccbd27d94907fe970e92b69c1ec21ef16c66fa9df917
+EBUILD gobject-introspection-1.58.3.ebuild 2214 BLAKE2B 8eab60230ba2403bcc0fd6f9bc7a992dfd2b62091aa4127be3879d5d2c6c4f9646f422a2e36d2251ef369c77f59c5489a7dfb8f023590a77ea81875bd03511cd SHA512 2233ef27e6ded47ee1be07d04a787fedaeba76955f6aa3bda9cf3856e56d18b74543d3f22979b659e8f1f0b8222bd1d3d33872ff482749896ec8d6519b842fa7
MISC metadata.xml 367 BLAKE2B b69aefd2ddda2f8e216d449de9ca13a5a8c473353b291bc5093ec2f6f3ac3346dc9fa25c85a64f15950813d9d6dfafd356a234c748436edb7639f37e95c71151 SHA512 1430924bf7430f4a409d6c3335a52b59567d5972440068e53e637d6c71486ef3e606ed9043184dfc168d731909e11c769042d2846e137312cd0ee0ce6f52e431
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.58.3.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.58.3.ebuild
new file mode 100644
index 000000000000..7f814af85a82
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.58.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1 toolchain-funcs
+
+DESCRIPTION="Introspection system for GObject-based libraries"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="cairo doctool test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( cairo )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# virtual/pkgconfig needed at runtime, bug #505408
+# We force glib and g-i to be in sync by this way as explained in bug #518424
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.58.0:2
+ doctool? ( dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}] )
+ virtual/libffi:=
+ virtual/pkgconfig
+ !<dev-lang/vala-0.20.0
+ ${PYTHON_DEPS}
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.19
+ sys-devel/bison
+ sys-devel/flex
+ test? ( x11-libs/cairo[glib] )
+" # autoreconf needs autoconf-archive
+# PDEPEND to avoid circular dependencies, bug #391213; but needed for tests, thus test DEPEND as well
+PDEPEND="cairo? ( x11-libs/cairo[glib] )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ if ! has_version "x11-libs/cairo[glib]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo -lcairo-gobject"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ fi
+
+ # To prevent crosscompiling problems, bug #414105
+ gnome2_src_configure \
+ --disable-static \
+ CC="$(tc-getCC)" \
+ YACC="$(type -p yacc)" \
+ $(use_with cairo) \
+ $(use_enable doctool)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+ "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"usr/share/aclocal || die
+}