summaryrefslogtreecommitdiff
path: root/dev-libs/gmime/gmime-2.6.23-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 14:22:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 14:22:04 +0000
commitad1d34add08caaf8d68c79e40f0a61c733fd68b8 (patch)
tree032c16fc1d6e2bcee85eb7e16e378692090a4d05 /dev-libs/gmime/gmime-2.6.23-r1.ebuild
parent1581db777aa413144ae9aaff70602eae670c8b93 (diff)
gentoo auto-resync : 01:01:2023 - 14:22:03
Diffstat (limited to 'dev-libs/gmime/gmime-2.6.23-r1.ebuild')
-rw-r--r--dev-libs/gmime/gmime-2.6.23-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-libs/gmime/gmime-2.6.23-r1.ebuild b/dev-libs/gmime/gmime-2.6.23-r1.ebuild
deleted file mode 100644
index cbeaa7bf8361..000000000000
--- a/dev-libs/gmime/gmime-2.6.23-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala flag-o-matic
-
-DESCRIPTION="Library for creating and parsing MIME messages"
-HOMEPAGE="http://spruce.sourceforge.net/gmime/"
-
-SLOT="2.6"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE="doc smime static-libs test vala"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.32.0:2
- sys-libs/zlib
- smime? ( >=app-crypt/gpgme-1.1.6:= )
- vala? (
- $(vala_depend)
- >=dev-libs/gobject-introspection-1.30.0:= )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.8
- virtual/libiconv
- virtual/pkgconfig
- doc? ( app-text/docbook-sgml-utils )
- test? ( app-crypt/gnupg )
-"
-# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
-
-src_prepare() {
- gnome2_src_prepare
- use vala && vala_src_prepare
-}
-
-src_configure() {
- [[ ${CHOST} == *-solaris* ]] && append-libs iconv
- gnome2_src_configure \
- --enable-cryptography \
- --disable-strict-parser \
- --disable-mono \
- $(use_enable smime) \
- $(use_enable static-libs static) \
- $(use_enable vala)
-}
-
-src_compile() {
- gnome2_src_compile
- if use doc; then
- emake -C docs/tutorial html
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- if use doc ; then
- docinto tutorial
- dodoc -r docs/tutorial/html/
- fi
-}