summaryrefslogtreecommitdiff
path: root/dev-libs/gjs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
commit78634f348a30a55cc55606ee1ecde032241ceaeb (patch)
tree528e39df571e37b31bfca1811c69bcc06c4af22f /dev-libs/gjs/files
parent434fbe89e81a1fe06d92676be72ab7f862cc3f53 (diff)
gentoo auto-resync : 19:03:2023 - 06:33:49
Diffstat (limited to 'dev-libs/gjs/files')
-rw-r--r--dev-libs/gjs/files/gjs-1.76.0-move_have_gtk4_to_the_appropriate_place.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/gjs/files/gjs-1.76.0-move_have_gtk4_to_the_appropriate_place.patch b/dev-libs/gjs/files/gjs-1.76.0-move_have_gtk4_to_the_appropriate_place.patch
new file mode 100644
index 000000000000..2bb80126507f
--- /dev/null
+++ b/dev-libs/gjs/files/gjs-1.76.0-move_have_gtk4_to_the_appropriate_place.patch
@@ -0,0 +1,38 @@
+# https://gitlab.gnome.org/GNOME/gjs/-/issues/532
+# https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/830/diffs?commit_id=83683d093c157828cf7787e53a32c586ae4e85d3
+diff --git a/installed-tests/js/meson.build b/installed-tests/js/meson.build
+index 6db887d2250face397079b03d215bbd13f455efb..1e953ceb7695356b6e854775e5db005a9c22e053 100644
+--- a/installed-tests/js/meson.build
++++ b/installed-tests/js/meson.build
+@@ -203,9 +203,13 @@ endif
+ # during build should be run using dbus-run-session
+
+ dbus_tests = ['GDBus']
+-if have_gtk4 and not get_option('skip_gtk_tests')
+- # FIXME: find out why GTK4 tries to acquire a message bus
+- dbus_tests += 'Gtk4'
++if not get_option('skip_gtk_tests')
++ have_gtk4 = dependency('gtk4', required: false).found()
++
++ if have_gtk4
++ # FIXME: find out why GTK4 tries to acquire a message bus
++ dbus_tests += 'Gtk4'
++ endif
+ endif
+
+ bus_config = files('../../test/test-bus.conf')
+diff --git a/meson.build b/meson.build
+index 3ac372a16b0bfaa364ed7422119f3e6e4af8971e..5c7703935b68c724347692ef5bf47a3edf868c61 100644
+--- a/meson.build
++++ b/meson.build
+@@ -679,10 +679,6 @@ endif
+
+ ### Tests and test setups ######################################################
+
+-if not get_option('skip_gtk_tests')
+- have_gtk4 = dependency('gtk4', required: false).found()
+-endif
+-
+ subdir('installed-tests')
+
+ # Note: The test program in test/ needs to be ported