summaryrefslogtreecommitdiff
path: root/dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-03 23:44:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-03 23:44:18 +0000
commit9becec60cd1423a327b86686a981699c0522cd79 (patch)
tree45888e8316556b1667e06ec2555a87601353747e /dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild
parentc44123f79f40edf5fe3d4b0d211d6aa68542abd2 (diff)
gentoo auto-resync : 03:02:2024 - 23:44:17
Diffstat (limited to 'dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild')
-rw-r--r--dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild b/dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild
new file mode 100644
index 000000000000..b8bd61f6bb19
--- /dev/null
+++ b/dev-libs/flatbuffers/flatbuffers-23.1.21.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Memory efficient serialization library"
+HOMEPAGE="
+ https://google.github.io/flatbuffers/
+ https://github.com/google/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/flatbuffers/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DOCS=( readme.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DFLATBUFFERS_BUILD_FLATLIB=$(usex static-libs)
+ -DFLATBUFFERS_BUILD_SHAREDLIB=ON
+ -DFLATBUFFERS_BUILD_TESTS=$(usex test)
+ -DFLATBUFFERS_BUILD_BENCHMARKS=OFF
+ )
+
+ cmake_src_configure
+}