summaryrefslogtreecommitdiff
path: root/dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild')
-rw-r--r--dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild b/dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..85b401a3de3a
--- /dev/null
+++ b/dev-libs/flatbuffers/flatbuffers-2.0.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Memory efficient serialization library"
+HOMEPAGE="https://google.github.io/flatbuffers/"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+# From 1.2.0->2.0.0, incremented SONAME, although the interface didn't actually change.
+# (Apparently to adopt semver.)
+SLOT="0/2"
+KEYWORDS="amd64 ~arm arm64 x86"
+IUSE="static-libs test"
+
+# out-of-source build broken, bug #842060
+RESTRICT="test !test? ( test )"
+
+DOCS=( readme.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.6-locales-detection-fixup.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DFLATBUFFERS_BUILD_FLATLIB=$(usex static-libs)
+ -DFLATBUFFERS_BUILD_SHAREDLIB=ON
+ -DFLATBUFFERS_BUILD_TESTS=$(usex test)
+ -DFLATBUFFERS_BUILD_BENCHMARKS=OFF
+ )
+
+ cmake_src_configure
+}