summaryrefslogtreecommitdiff
path: root/dev-libs/fcgi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/fcgi/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/fcgi/files')
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.0-Makefile.patch24
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.0-clientdata-pointer.patch96
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.0-html-updates.patch65
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.1_pre0311112127-gcc44.patch10
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch21
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-poll.patch80
6 files changed, 0 insertions, 296 deletions
diff --git a/dev-libs/fcgi/files/fcgi-2.4.0-Makefile.patch b/dev-libs/fcgi/files/fcgi-2.4.0-Makefile.patch
deleted file mode 100644
index dad4cd6e02dd..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.0-Makefile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: fcgi-2.4.0/cgi-fcgi/Makefile.am
-===================================================================
---- fcgi-2.4.0.orig/cgi-fcgi/Makefile.am
-+++ fcgi-2.4.0/cgi-fcgi/Makefile.am
-@@ -11,5 +11,5 @@ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.
- LIBDIR = ../libfcgi
- LIBFCGI = $(LIBDIR)/libfcgi.la
-
--LDADD = $(LIBFCGI)
-+LDADD = $(LIBFCGI) -lm
- cgi_fcgi_SOURCES = $(INCLUDE_FILES) cgi-fcgi.c
-Index: fcgi-2.4.0/examples/Makefile.am
-===================================================================
---- fcgi-2.4.0.orig/examples/Makefile.am
-+++ fcgi-2.4.0/examples/Makefile.am
-@@ -21,7 +21,7 @@ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.
- LIBDIR = ../libfcgi
- LIBFCGI = $(LIBDIR)/libfcgi.la
-
--LDADD = $(LIBFCGI)
-+LDADD = $(LIBFCGI) -lm
-
- echo_SOURCES = $(INCLUDE_FILES) echo.c
- echo_x_SOURCES = $(INCLUDE_FILES) echo-x.c
diff --git a/dev-libs/fcgi/files/fcgi-2.4.0-clientdata-pointer.patch b/dev-libs/fcgi/files/fcgi-2.4.0-clientdata-pointer.patch
deleted file mode 100644
index ba4793765d5e..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.0-clientdata-pointer.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Index: fcgi-2.4.0/cgi-fcgi/cgi-fcgi.c
-===================================================================
---- fcgi-2.4.0.orig/cgi-fcgi/cgi-fcgi.c
-+++ fcgi-2.4.0/cgi-fcgi/cgi-fcgi.c
-@@ -21,6 +21,7 @@ static const char rcsid[] = "$Id: cgi-fc
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
-
- #include "fcgi_config.h"
-
-@@ -145,7 +146,7 @@ static FCGI_BeginRequestBody MakeBeginRe
-
-
- static int bytesToRead; /* number of bytes to read from Web Server */
--static int appServerSock = -1; /* Socket connected to FastCGI application,
-+static size_t appServerSock = -1; /* Socket connected to FastCGI application,
- * used by AppServerReadHandler and
- * AppServerWriteHandler. */
- static Buffer fromAS; /* Bytes read from the FCGI application server. */
-@@ -640,7 +641,7 @@ static int ParseArgs(int argc, char *arg
- }
- if((av[ac] = (char *)malloc(strlen(tp1)+1)) == NULL) {
- fprintf(stderr, "Cannot allocate %d bytes\n",
-- strlen(tp1)+1);
-+ (int)strlen(tp1)+1);
- exit(-1);
- }
- strcpy(av[ac++], tp1);
-Index: fcgi-2.4.0/examples/threaded.c
-===================================================================
---- fcgi-2.4.0.orig/examples/threaded.c
-+++ fcgi-2.4.0/examples/threaded.c
-@@ -24,7 +24,7 @@ static int counts[THREAD_COUNT];
-
- static void *doit(void *a)
- {
-- int rc, i, thread_id = (int)a;
-+ size_t rc, i, thread_id = (size_t)a;
- pid_t pid = getpid();
- FCGX_Request request;
- char *server_name;
-@@ -53,7 +53,7 @@ static void *doit(void *a)
- "<h1>FastCGI Hello! (multi-threaded C, fcgiapp library)</h1>"
- "Thread %d, Process %ld<p>"
- "Request counts for %d threads running on host <i>%s</i><p><code>",
-- thread_id, pid, THREAD_COUNT, server_name ? server_name : "?");
-+ (int)thread_id, pid, THREAD_COUNT, server_name ? server_name : "?");
-
- sleep(2);
-
-@@ -71,7 +71,7 @@ static void *doit(void *a)
-
- int main(void)
- {
-- int i;
-+ size_t i;
- pthread_t id[THREAD_COUNT];
-
- FCGX_Init();
-Index: fcgi-2.4.0/include/fcgios.h
-===================================================================
---- fcgi-2.4.0.orig/include/fcgios.h
-+++ fcgi-2.4.0/include/fcgios.h
-@@ -93,7 +93,7 @@ extern "C" {
- # if defined(__STDC__) || defined(__cplusplus)
- typedef void *ClientData;
- # else
-- typedef int *ClientData;
-+ typedef size_t *ClientData;
- # endif /* __STDC__ */
- #define _CLIENTDATA
- #endif
-Index: fcgi-2.4.0/libfcgi/os_unix.c
-===================================================================
---- fcgi-2.4.0.orig/libfcgi/os_unix.c
-+++ fcgi-2.4.0/libfcgi/os_unix.c
-@@ -1155,7 +1155,7 @@ int OS_Accept(int listen_sock, int fail_
-
- for (;;) {
- do {
--#ifdef HAVE_SOCKLEN
-+#ifdef HAVE_SYS_SOCKET_H
- socklen_t len = sizeof(sa);
- #else
- int len = sizeof(sa);
-@@ -1255,7 +1255,7 @@ int OS_IsFcgi(int sock)
- struct sockaddr_in in;
- struct sockaddr_un un;
- } sa;
--#ifdef HAVE_SOCKLEN
-+#ifdef HAVE_SYS_SOCKET_H
- socklen_t len = sizeof(sa);
- #else
- int len = sizeof(sa);
diff --git a/dev-libs/fcgi/files/fcgi-2.4.0-html-updates.patch b/dev-libs/fcgi/files/fcgi-2.4.0-html-updates.patch
deleted file mode 100644
index ca10a6a6039b..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.0-html-updates.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Index: fcgi-2.4.0/doc/fcgi-devel-kit.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-devel-kit.htm
-+++ fcgi-2.4.0/doc/fcgi-devel-kit.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <P CLASS="c1">
-- <IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"><BR CLEAR="all">
-+ <IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"><BR CLEAR="all">
- </P>
- <H3 CLASS="c2">
- FastCGI Developer&#39;s Kit
-Index: fcgi-2.4.0/doc/fcgi-java.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-java.htm
-+++ fcgi-2.4.0/doc/fcgi-java.htm
-@@ -20,7 +20,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
-Index: fcgi-2.4.0/doc/fcgi-perf.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-perf.htm
-+++ fcgi-2.4.0/doc/fcgi-perf.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
-Index: fcgi-2.4.0/doc/fcgi-perl.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-perl.htm
-+++ fcgi-2.4.0/doc/fcgi-perl.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
-
-Index: fcgi-2.4.0/doc/fcgi-tcl.htm
-===================================================================
---- fcgi-2.4.0.orig/doc/fcgi-tcl.htm
-+++ fcgi-2.4.0/doc/fcgi-tcl.htm
-@@ -19,7 +19,7 @@
- </HEAD>
- <BODY>
- <DIV CLASS="c1">
-- <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="../images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
-+ <A HREF="http://fastcgi.com"><IMG BORDER="0" SRC="images/fcgi-hd.gif" ALT="[[FastCGI]]"></A>
- </DIV>
- <BR CLEAR="all">
- <DIV CLASS="c1">
diff --git a/dev-libs/fcgi/files/fcgi-2.4.1_pre0311112127-gcc44.patch b/dev-libs/fcgi/files/fcgi-2.4.1_pre0311112127-gcc44.patch
deleted file mode 100644
index a0b59f766a89..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.1_pre0311112127-gcc44.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- fcgi-2.4.1-SNAP-0311112127-orig/include/fcgio.h
-+++ fcgi-2.4.1-SNAP-0311112127/include/fcgio.h
-@@ -31,6 +31,7 @@
- #define FCGIO_H
-
- #include <iostream>
-+#include <cstdio>
-
- #include "fcgiapp.h"
-
diff --git a/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch b/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch
deleted file mode 100644
index e53c7e9d550b..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: fcgi-2.4.1-SNAP-0910052249/libfcgi/Makefile.am
-===================================================================
---- fcgi-2.4.1-SNAP-0910052249.orig/libfcgi/Makefile.am
-+++ fcgi-2.4.1-SNAP-0910052249/libfcgi/Makefile.am
-@@ -9,8 +9,7 @@ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h
- $(INCLUDEDIR)/fcgi_stdio.h \
- $(INCLUDEDIR)/fcgios.h
-
--lib_LTLIBRARIES = libfcgi.la @LIBFCGIXX@
--EXTRA_LTLIBRARIES = libfcgi++.la
-+lib_LTLIBRARIES = libfcgi.la libfcgi++.la
-
- libfcgi_la_SOURCES = $(INCLUDE_FILES) \
- fcgiapp.c \
-@@ -23,5 +22,5 @@ libfcgi___la_SOURCES = $(INCLUDE_FILES)
- $(INCLUDEDIR)/fcgio.h \
- fcgio.cpp
- libfcgi___la_CFLAGS = @PTHREAD_CFLAGS@
--libfcgi___la_LDFLAGS = -lfcgi -rpath @libdir@
-+libfcgi___la_LIBADD = libfcgi.la
-
diff --git a/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-poll.patch b/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-poll.patch
deleted file mode 100644
index 82b9f15a846c..000000000000
--- a/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-poll.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -uNr fcgi-2.4.1-SNAP-0910052249.orig/libfcgi/os_unix.c fcgi-2.4.1-SNAP-0910052249/libfcgi/os_unix.c
---- fcgi-2.4.1-SNAP-0910052249.orig/libfcgi/os_unix.c 2015-02-06 21:49:40.677082591 -0200
-+++ fcgi-2.4.1-SNAP-0910052249/libfcgi/os_unix.c 2015-02-06 21:54:23.147097903 -0200
-@@ -42,6 +42,7 @@
- #include <sys/time.h>
- #include <sys/un.h>
- #include <signal.h>
-+#include <poll.h>
-
- #ifdef HAVE_NETDB_H
- #include <netdb.h>
-@@ -103,6 +104,9 @@
- static int shutdownPending = FALSE;
- static int shutdownNow = FALSE;
-
-+static int libfcgiOsClosePollTimeout = 2000;
-+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
-+
- void OS_ShutdownPending()
- {
- shutdownPending = TRUE;
-@@ -169,6 +173,16 @@
- if(libInitialized)
- return 0;
-
-+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
-+ if(libfcgiOsClosePollTimeoutStr) {
-+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
-+ }
-+
-+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
-+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
-+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
-+ }
-+
- asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
- if(asyncIoTable == NULL) {
- errno = ENOMEM;
-@@ -780,19 +794,16 @@
- {
- if (shutdown(fd, 1) == 0)
- {
-- struct timeval tv;
-- fd_set rfds;
-+ struct pollfd pfd;
- int rv;
- char trash[1024];
-
-- FD_ZERO(&rfds);
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
- do
- {
-- FD_SET(fd, &rfds);
-- tv.tv_sec = 2;
-- tv.tv_usec = 0;
-- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
-+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
- }
- while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
- }
-@@ -1142,13 +1153,11 @@
- */
- static int is_af_unix_keeper(const int fd)
- {
-- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
-- fd_set read_fds;
--
-- FD_ZERO(&read_fds);
-- FD_SET(fd, &read_fds);
-+ struct pollfd pfd;
-+ pfd.fd = fd;
-+ pfd.events = POLLIN;
-
-- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
-+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
- }
-
- /*