summaryrefslogtreecommitdiff
path: root/dev-libs/eventlog/eventlog-0.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/eventlog/eventlog-0.2.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/eventlog/eventlog-0.2.12.ebuild')
-rw-r--r--dev-libs/eventlog/eventlog-0.2.12.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/eventlog/eventlog-0.2.12.ebuild b/dev-libs/eventlog/eventlog-0.2.12.ebuild
new file mode 100644
index 000000000000..303e1a09d93f
--- /dev/null
+++ b/dev-libs/eventlog/eventlog-0.2.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit libtool eutils
+
+DESCRIPTION="Support library for syslog-ng"
+HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
+SRC_URI="http://www.balabit.com/downloads/files/eventlog/0.2//eventlog_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~m68k-mint"
+IUSE="static-libs"
+
+DEPEND=""
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ DOCS="AUTHORS CREDITS ChangeLog NEWS PORTS README" \
+ default
+ prune_libtool_files
+}