summaryrefslogtreecommitdiff
path: root/dev-libs/eb/eb-4.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/eb/eb-4.4.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/eb/eb-4.4.1-r1.ebuild')
-rw-r--r--dev-libs/eb/eb-4.4.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/eb/eb-4.4.1-r1.ebuild b/dev-libs/eb/eb-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..0942eb7c1545
--- /dev/null
+++ b/dev-libs/eb/eb-4.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="EB is a C library and utilities for accessing CD-ROM books"
+HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/eb/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/misc/eb/${P}.tar.lzma"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="ipv6 nls threads"
+
+RDEPEND="
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS ChangeLog{,.0,.1,.2} NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable threads pthread) \
+ --with-pkgdocdir=/usr/share/doc/${PF}/html
+}