summaryrefslogtreecommitdiff
path: root/dev-libs/dqlite/dqlite-1.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-19 17:59:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-19 17:59:37 +0000
commit150a86a9cb006b4800d6517d58532b8a556fec1e (patch)
tree0cea769c7bef669c4dfe19e7805593f6f34033fb /dev-libs/dqlite/dqlite-1.14.0.ebuild
parent1cb0dd91756f77b25d6cc22318dc85187ed084cb (diff)
gentoo auto-resync : 19:01:2023 - 17:59:37
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.14.0.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.14.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.14.0.ebuild b/dev-libs/dqlite/dqlite-1.14.0.ebuild
new file mode 100644
index 000000000000..c0cbc911e373
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.14.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/1.12.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv:=
+ >=dev-libs/raft-0.17.1:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/raft-0.13.0[lz4,test] )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/dqlite-1.12.0-disable-werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-backtrace
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+
+ # Will build a bundled libsqlite3.so.
+ --enable-build-sqlite=no
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}