summaryrefslogtreecommitdiff
path: root/dev-libs/dotconf/dotconf-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/dotconf/dotconf-1.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/dotconf/dotconf-1.3-r1.ebuild')
-rw-r--r--dev-libs/dotconf/dotconf-1.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-1.3-r1.ebuild b/dev-libs/dotconf/dotconf-1.3-r1.ebuild
new file mode 100644
index 000000000000..ca952cd3a5d5
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=sys-devel/autoconf-2.58"
+RDEPEND=""
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+pkg_postinst() {
+ ewarn 'This version requires that you run revdep-rebuild after'
+ ewarn 'the upgrade.'
+}