summaryrefslogtreecommitdiff
path: root/dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-18 07:50:03 +0000
commitf8730c9e91ed2ce341e231c5adffb5f003f77678 (patch)
treeb4ecbb2994744fab3e10498bf64ef81d01ca550d /dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch
parent3e02de9a64a4e3d1f1af271a9da7ff7bbf8d86c8 (diff)
gentoo auto-resync : 18:12:2023 - 07:50:03
Diffstat (limited to 'dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch')
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch35
1 files changed, 21 insertions, 14 deletions
diff --git a/dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch b/dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch
index f4c4904a235e..4f5e6339d8aa 100644
--- a/dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch
+++ b/dev-libs/dmalloc/files/dmalloc-5.6.5-configure-c99.patch
@@ -1,6 +1,12 @@
+From debb91ecdd39a7039abdc6b2fb4c9b79956fc758 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 17 Dec 2023 14:35:31 +0200
+Subject: [PATCH 4/5] Fix c99 compatibility in configure script
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
--- a/configure.ac
+++ b/configure.ac
-@@ -482,19 +482,20 @@ AC_MSG_RESULT([$ac_cv_pnt_arith_type])
+@@ -486,19 +486,20 @@ AC_MSG_RESULT([$ac_cv_pnt_arith_type])
AC_CHECK_FUNCS(abort)
AC_MSG_CHECKING([abort safe])
AC_RUN_IFELSE([AC_LANG_SOURCE([[
@@ -24,7 +30,7 @@
/* it should be already 0s */
start = malloc (number * size);
pnt = start;
-@@ -504,7 +505,7 @@ char *calloc (int number, int size) {
+@@ -508,7 +509,7 @@ char *calloc (int number, int size) {
}
char *realloc (char *old_pnt, int new_size) {
char *start, *pnt, *end;
@@ -33,7 +39,15 @@
start = malloc (new_size);
pnt = start;
end = start + new_size;
-@@ -647,6 +648,7 @@ fi
+@@ -549,6 +550,7 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ AC_CHECK_FUNCS(getenv)
+ AC_MSG_CHECKING([getenv safe])
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
++#include <stdlib.h>
+ static char heap_mem[102400], *heap_p = heap_mem;
+ free (char *pnt) {
+ }
+@@ -651,6 +653,7 @@ fi
#
AC_MSG_CHECKING([constructor attribute])
AC_RUN_IFELSE([AC_LANG_SOURCE([[
@@ -41,7 +55,7 @@
/* if we call the loc_con constructor then exit with error code 0 */
static void loc_con() __attribute__((constructor));
static void loc_con() { exit(0); }
-@@ -662,6 +664,7 @@ int main() { return 1; }
+@@ -666,6 +669,7 @@ int main() { return 1; }
#
AC_MSG_CHECKING([destructor attribute])
AC_RUN_IFELSE([AC_LANG_SOURCE([[
@@ -49,13 +63,6 @@
/* if we call the loc_decon destructor then exit with error code 0 */
static void loc_decon() __attribute__((destructor));
static void loc_decon() { exit(0); }
---- a/configure.ac
-+++ b/configure.ac
-@@ -546,6 +546,7 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
- AC_CHECK_FUNCS(getenv)
- AC_MSG_CHECKING([getenv safe])
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
-+#include <stdlib.h>
- static char heap_mem[102400], *heap_p = heap_mem;
- free (char *pnt) {
- }
+--
+2.43.0
+