summaryrefslogtreecommitdiff
path: root/dev-libs/dbus-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/dbus-glib
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/dbus-glib')
-rw-r--r--dev-libs/dbus-glib/Manifest3
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.110.ebuild35
-rw-r--r--dev-libs/dbus-glib/files/dbus-glib-0.110-config-glib-genmarshal.conf76
3 files changed, 106 insertions, 8 deletions
diff --git a/dev-libs/dbus-glib/Manifest b/dev-libs/dbus-glib/Manifest
index 27d3ef61445b..fddd9920b417 100644
--- a/dev-libs/dbus-glib/Manifest
+++ b/dev-libs/dbus-glib/Manifest
@@ -1,3 +1,4 @@
+AUX dbus-glib-0.110-config-glib-genmarshal.conf 3281 BLAKE2B 5724ec3aa555d71b26739a8d4ded9773872fdfacdd6657070fb8ccd2b4164180655ecc7b83ef0c9440b867394c766c9276662d4d278a9d988909fba04b6d744d SHA512 76dafdb81234600b0717e79d1ce8cdc6668aaacbed607f929bc9d299dcad0330ccf62e2bbfe73338526770faaa40f9f5564a108d8830484bde2ab7a78cae6e03
DIST dbus-glib-0.110.tar.gz 836497 BLAKE2B d936402bbaa5c354b2730cbace273974ec0133db052503fea2780d70b128e50e4fdf54f6ebfeed024eb5602fa3725a40627e27320a4727647299f74b2eb75c85 SHA512 c40ccf7118d4951f0e09082216ccd26f21ee906bdf96d912611d3cd29badd7ef446bea74e19f26c28ebceb9e19bb659d11c643c3e712dac499df12907be88a54
-EBUILD dbus-glib-0.110.ebuild 1931 BLAKE2B a44bdce16b8c41a503fa3fbd1a00d2004e4bd74972c7c01b86ee298575dca57b37df94fb8ff67ae81d2623f23354108dced126948dc8b1b65056c458b5805947 SHA512 19a2e03cacc7cdf83dfb17a814bbe966ba66bc473357ffaab5eb91c7f57276d7e4ba1f975d2594f88dc82090547333f94db99618708c691408af2df442dadfa7
+EBUILD dbus-glib-0.110.ebuild 2550 BLAKE2B 62c0efc5a9321aa72c27481db578bfa5ad252e39d78e313171a7314e2d6fcac4413fce9e5a98423e7249dd3f3333405ba25af399ab1e7a4e3d25dc46a3a59131 SHA512 979283a5e976572055562ae2558ec616f53647dcf6aa425ad925509bbabe2fc0c57a6b1f50468ac0a27b6f38a2af5989db7523af4e989567b863ba69235d5bee
MISC metadata.xml 326 BLAKE2B 83337c958adc4c6e7c8ffe6c166598af211c2688753440bbf3978e3bca37553eb90d3d0c8b0423d422691afcbae51c872b2149c97a76206bd090e379e7fff422 SHA512 65080e75b6d877c594f4f4a1e931d26885b3059f43d567ccd640f089cfc5d7969963cd5d8fa51200dbbafcaf93eddf6faa5cf7d548b60809b808543dcb3c2af6
diff --git a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
index 9e47f93d6afc..2d3b43af461d 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit bash-completion-r1 eutils ltprune multilib-minimal
+EAPI=7
+inherit autotools bash-completion-r1 multilib-minimal toolchain-funcs
DESCRIPTION="D-Bus bindings for glib"
HOMEPAGE="https://dbus.freedesktop.org/"
@@ -14,25 +14,35 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd6
IUSE="debug static-libs test"
RESTRICT="!test? ( test )"
-CDEPEND="
+DEPEND="
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
>=sys-apps/dbus-1.8[${MULTILIB_USEDEP}]
"
-DEPEND="${CDEPEND}
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/glib-2.40:2
+ >=sys-apps/dbus-1.8
>=dev-util/glib-utils-2.40
>=dev-util/gtk-doc-am-1.14
virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}"
+" # CBUILD dependencies are needed to make a native tool while cross-compiling.
DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+PATCHES=( "${FILESDIR}"/${P}-config-glib-genmarshal.conf )
+
set_TBD() {
# out of sources build dir for make check
export TBD="${BUILD_DIR}-tests"
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myconf=(
--localstatedir="${EPREFIX}"/var
@@ -42,6 +52,15 @@ multilib_src_configure() {
$(use_enable static-libs static)
)
+ # Configure a CBUILD directory to make a native build tool.
+ if tc-is-cross-compiler; then
+ mkdir "${BUILD_DIR}-build" || die
+ cd "${BUILD_DIR}-build" || die
+ ECONF_SOURCE="${S}" econf_build
+ myconf+=( --with-dbus-binding-tool="$PWD/dbus/dbus-binding-tool" )
+ cd - || die
+ fi
+
ECONF_SOURCE="${S}" econf "${myconf[@]}"
ln -s "${S}"/doc/reference/html doc/reference/html || die #460042
@@ -60,6 +79,8 @@ multilib_src_configure() {
}
multilib_src_compile() {
+ tc-is-cross-compiler && emake -C "${BUILD_DIR}-build"
+
emake
if use test; then
@@ -82,5 +103,5 @@ multilib_src_install_all() {
newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
rm -rf "${ED}"/etc/bash_completion.d || die
- prune_libtool_files
+ find "${ED}" -type f -name '*.la' -delete || die
}
diff --git a/dev-libs/dbus-glib/files/dbus-glib-0.110-config-glib-genmarshal.conf b/dev-libs/dbus-glib/files/dbus-glib-0.110-config-glib-genmarshal.conf
new file mode 100644
index 000000000000..463638710ad0
--- /dev/null
+++ b/dev-libs/dbus-glib/files/dbus-glib-0.110-config-glib-genmarshal.conf
@@ -0,0 +1,76 @@
+From 39f0ae6152acfb3d8ca086090a02e0aa8742f050 Mon Sep 17 00:00:00 2001
+From: "Yann E. MORIN" <yann.morin.1998@free.fr>
+Date: Sun, 2 Dec 2018 16:26:07 +0100
+Subject: [PATCH] buildsys: use variable for glib-genmarshal
+
+When doing cross-compilation, the path returned by pkg-config for
+glib-genmarshal can be incorrect (because it is the runtime path,
+not the build-time path).
+
+Change configure.ac to use pkg-config to get the variable.
+
+This allows overridig the path at configure time, by using the configure
+option GLIB_GENMARSHAL=/path/toglib-genmarshal
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+[smcv: Fix typo in commit message]
+Reviewed-by: Simon McVittie <smcv@collabora.com>
+---
+ configure.ac | 4 ++--
+ dbus/Makefile.am | 4 ++--
+ dbus/examples/statemachine/Makefile.am | 4 ++--
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e00bc38..8be3147 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -267,8 +267,8 @@ AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_32],
+ [Warn on use of APIs deprecated before GLib 2.32])
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.40, gobject-2.0 >= 2.40, gio-2.0 >= 2.40])
+
+-GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
+-AC_SUBST(GLIB_GENMARSHAL)
++PKG_CHECK_VAR([GLIB_GENMARSHAL], [glib-2.0], [glib_genmarshal],,
++ [AC_MSG_ERROR([cannot find glib-genmarshal])])
+
+ dnl GLib flags
+ AC_SUBST(GLIB_CFLAGS)
+diff --git a/dbus/Makefile.am b/dbus/Makefile.am
+index 37c6334..2e8cb27 100644
+--- a/dbus/Makefile.am
++++ b/dbus/Makefile.am
+@@ -87,10 +87,10 @@ dbus_binding_tool_LDADD= $(builddir)/libdbus-gtool.la $(builddir)/libdbus-glib-1
+ ## we just rebuilt these manually and check them into cvs; easier than
+ ## convincing automake/make to do this properly
+ regenerate-built-sources:
+- @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --header > dbus-gmarshal.h && \
++ $(GLIB_GENMARSHAL) --prefix=_dbus_g_marshal dbus-gmarshal.list --header > dbus-gmarshal.h && \
+ echo '#include <config.h>' > dbus-gmarshal.c && \
+ echo '#include "dbus-gmarshal.h"' >> dbus-gmarshal.c && \
+- @GLIB_GENMARSHAL@ --prefix=_dbus_g_marshal dbus-gmarshal.list --body >> dbus-gmarshal.c
++ $(GLIB_GENMARSHAL) --prefix=_dbus_g_marshal dbus-gmarshal.list --body >> dbus-gmarshal.c
+
+
+ completiondir = $(sysconfdir)/bash_completion.d
+diff --git a/dbus/examples/statemachine/Makefile.am b/dbus/examples/statemachine/Makefile.am
+index 187b044..c8fe029 100644
+--- a/dbus/examples/statemachine/Makefile.am
++++ b/dbus/examples/statemachine/Makefile.am
+@@ -35,11 +35,11 @@ statemachine-glue.h: statemachine.xml
+
+ sm-marshal.c: Makefile sm-marshal.list
+ echo "#include <config.h>" > $@.tmp
+- @GLIB_GENMARSHAL@ --prefix=sm_marshal $(srcdir)/sm-marshal.list --header --body >> $@.tmp
++ $(GLIB_GENMARSHAL) --prefix=sm_marshal $(srcdir)/sm-marshal.list --header --body >> $@.tmp
+ mv $@.tmp $@
+
+ sm-marshal.h: Makefile sm-marshal.list
+- @GLIB_GENMARSHAL@ --prefix=sm_marshal $(srcdir)/sm-marshal.list --header > $@.tmp && mv $@.tmp $@
++ $(GLIB_GENMARSHAL) --prefix=sm_marshal $(srcdir)/sm-marshal.list --header > $@.tmp && mv $@.tmp $@
+
+ BUILT_SOURCES += sm-marshal.c sm-marshal.h
+
+--
+GitLab
+